Skip to content

← Actionable
High, CVSS 8.2amended

protobufjs-cli: Code injection in pbjs static output from crafted JSON descriptor names

CVE-2026-54271GHSA-pr59-h9ph-3fr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobufjs-cli 2.5.0, 1.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm protobufjs-cli

    Affected
    <= 1.3.1>= 2.0.0, <= 2.4.2
    Fixed in
    2.5.0, 1.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L
EPSS
  • CVE-2026-54271: 0.30% estimated exploitation activity in the next 30 days; percentile 23.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A previous fix for unsafe name handling in pbjs static / static-module code generation was incomplete. Affected versions of protobufjs-cli could still emit unsafe JavaScript references when generating static output from crafted JSON descriptor input. The common case of parsing schemas from .proto files is not affected. This is a bypass of GHSA-6r35-46g8-jcw9 / CVE-2026-44295. Impact An attacker who can provide or influence pre-parsed JSON descriptors passed to pbjs static code generation may be able to cause generated JavaScript output to contain attacker-controlled code. The injected code may execute if the generated file is later executed or imported and an affected generated API path is invoked. Preconditions The application or build process must run pbjs static code generation on a pre-parsed JSON descriptor influenced by an attacker. The generated JavaScript file must subsequently be executed or imported. An affected generated API path must be invoked. Workarounds Do not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pr59-h9ph-3fr8

  2. Revision 1 · created ·

    Published from osv record GHSA-pr59-h9ph-3fr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54271

Advisory: protobufjs-cli: Code injection in pbjs static output from crafted JSON descriptor names
IDs: CVE-2026-54271, GHSA-pr59-h9ph-3fr8
Record: https://patchnext.com/advisories/cve-2026-54271 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: protobufjs-cli 2.5.0, 1.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm protobufjs-cli: affected <= 1.3.1; >= 2.0.0, <= 2.4.2; fixed in 2.5.0, 1.3.2

## Suggested inspection (read-only)
- `npm ls protobufjs-cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on protobufjs-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pr59-h9ph-3fr8 (OSV record GHSA-pr59-h9ph-3fr8 lists affected ranges: npm protobufjs-cli >=0 =2.0.0 <2.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pr59-h9ph-3fr8 (GitHub-reviewed advisory GHSA-pr59-h9ph-3fr8 lists affected ranges: npm protobufjs-cli >=0 =2.0.0 <=2.4.2)

Commands are suggestions: review each one before running it.

Loading voting…