@angular/common: Denial of Service (DoS) via OOM in Date Formatting (formatDate)
CVE-2026-54268GHSA-48r7-hpm6-gfxm
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/common
- Affected
- >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.17>= 20.0.0-next.0, < 20.3.25<= 19.2.25
- Fixed in
- 20.3.25, 22.0.1, 21.2.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-48r7-hpm6-gfxm lists affected ranges: npm @angular/common >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48r7-hpm6-gfxm lists affected ranges: npm @angular/common >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54268: 0.58% estimated exploitation activity in the next 30 days; percentile 47.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Denial of Service (DoS) vulnerability exists in the @angular/common package of the Angular framework. The formatDate function, which is also utilized by the standard Angular DatePipe, does not properly limit or validate the length of the format parameter. When parsing a maliciously crafted, excessively long date format string (e.g., a repeating pattern or very large string), the internal parser splits the string iteratively using a regular expression loop. This results in uncontrolled resource consumption (high CPU utilization and excessive memory allocations), leading to a Denial of Service (DoS). Impact 1. Server-Side Rendering (SSR) In Angular applications that leverage Server-Side Rendering, an attacker can supply a malicious payload with an excessively long date format string. Processing this on the server causes high CPU usage and triggers a JavaScript heap out of memory crash, rendering the application unavailable to all users. 2. Client-Side Rendering (CSR) In standard…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-48r7-hpm6-gfxm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-48r7-hpm6-gfxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54268 Advisory: @angular/common: Denial of Service (DoS) via OOM in Date Formatting (formatDate) IDs: CVE-2026-54268, GHSA-48r7-hpm6-gfxm Record: https://patchnext.com/advisories/cve-2026-54268 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/common 22.0.1, 21.2.17, 20.3.25. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/common: affected >= 22.0.0-next.0, < 22.0.1; >= 21.0.0-next.0, < 21.2.17; >= 20.0.0-next.0, < 20.3.25; <= 19.2.25; fixed in 20.3.25, 22.0.1, 21.2.17 ## Suggested inspection (read-only) - `npm ls @angular/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-48r7-hpm6-gfxm (OSV record GHSA-48r7-hpm6-gfxm lists affected ranges: npm @angular/common >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25) - Verified: https://github.com/advisories/GHSA-48r7-hpm6-gfxm (GitHub-reviewed advisory GHSA-48r7-hpm6-gfxm lists affected ranges: npm @angular/common >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25) Commands are suggestions: review each one before running it.
Loading voting…