Skip to content

← Actionable
High, CVSS 8.3amended

@angular/service-worker: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker

CVE-2026-54264GHSA-qxh6-94w6-9r5p

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @angular/service-worker

    Affected
    >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.17>= 20.0.0-next.0, < 20.3.25<= 19.2.25
    Fixed in
    20.3.25, 22.0.1, 21.2.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-54264: 0.39% estimated exploitation activity in the next 30 days; percentile 33.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An information disclosure vulnerability exists in the @angular/service-worker package of the Angular framework. When the Service Worker fetches assets, it preserves metadata (such as headers) from the original request. However, on cross-origin redirects, the Service Worker fails to strip sensitive headers, violating the Fetch redirect algorithm. This allows a remote attacker to obtain sensitive credentials (e.g., Authorization tokens, Proxy-Authorization credentials, or session cookies) by triggering a cross-origin redirect to an untrusted external origin. Impact If an application configured with the Angular Service Worker fetches assets with credential headers (such as Authorization header), and one of those requests is redirected to a different origin, the Service Worker will forward those headers to the new origin. This exposes critical credentials and session identifiers to unauthorized third-party servers. Attack Preconditions For this vulnerability to be exploitable: 1.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qxh6-94w6-9r5p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qxh6-94w6-9r5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54264

Advisory: @angular/service-worker: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker
IDs: CVE-2026-54264, GHSA-qxh6-94w6-9r5p
Record: https://patchnext.com/advisories/cve-2026-54264 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @angular/service-worker 22.0.1, 21.2.17, 20.3.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @angular/service-worker: affected >= 22.0.0-next.0, < 22.0.1; >= 21.0.0-next.0, < 21.2.17; >= 20.0.0-next.0, < 20.3.25; <= 19.2.25; fixed in 20.3.25, 22.0.1, 21.2.17

## Suggested inspection (read-only)
- `npm ls @angular/service-worker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/service-worker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qxh6-94w6-9r5p (OSV record GHSA-qxh6-94w6-9r5p lists affected ranges: npm @angular/service-worker >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25)
- Verified: https://github.com/advisories/GHSA-qxh6-94w6-9r5p (GitHub-reviewed advisory GHSA-qxh6-94w6-9r5p lists affected ranges: npm @angular/service-worker >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25)

Commands are suggestions: review each one before running it.

Loading voting…