Wagtail: Reflected XSS in dynamic image URL generator view
CVE-2026-54263GHSA-23m2-mghx-vqmf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 7.4.2, 7.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- >= 7.3, < 7.3.3>= 7.4, < 7.4.2
- Fixed in
- 7.3.3, 7.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-616 lists affected ranges: PyPI wagtail >=7.3 <7.3.3 (fixed), >=7.4 <7.4.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-23m2-mghx-vqmf lists affected ranges: PyPI wagtail >=7.3 =7.4 <7.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-54263: 0.36% estimated exploitation activity in the next 30 days; percentile 29.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 7.3.3 and 7.4.2. Workarounds For sites that cannot easily upgrade to a current supported version, the vulnerability can be patched by adding the following code to urls.py URL pattern declarations to override the vulnerable view. This disables the admin dynamic image preview functionality, while the public-facing dynamic image serve view still works. Acknowledgements Many thanks to Thibaud Colas…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-23m2-mghx-vqmf
- Revision 1 · created ·
Published from osv record PYSEC-2026-616
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54263 Advisory: Wagtail: Reflected XSS in dynamic image URL generator view IDs: CVE-2026-54263, GHSA-23m2-mghx-vqmf Record: https://patchnext.com/advisories/cve-2026-54263 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 7.4.2, 7.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected >= 7.3, < 7.3.3; >= 7.4, < 7.4.2; fixed in 7.3.3, 7.4.2 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-616 (OSV record PYSEC-2026-616 lists affected ranges: PyPI wagtail >=7.3 <7.3.3 (fixed), >=7.4 <7.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-23m2-mghx-vqmf (GitHub-reviewed advisory GHSA-23m2-mghx-vqmf lists affected ranges: PyPI wagtail >=7.3 =7.4 <7.4.2) Commands are suggestions: review each one before running it.
Loading voting…