Wagtail: Improper permission handling in image preview
CVE-2026-54261GHSA-r6p4-grq7-xm4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 7.4.2, 7.3.3, 7.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- < 7.0.8>= 7.1, < 7.3.3>= 7.4, < 7.4.2
- Fixed in
- 7.0.8, 7.3.3, 7.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-614 lists affected ranges: PyPI wagtail >=0 <7.0.8 (fixed), >=7.1 <7.3.3 (fixed), >=7.4 <7.4.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r6p4-grq7-xm4m lists affected ranges: PyPI wagtail >=0 =7.1 =7.4 <7.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-54261: 0.34% estimated exploitation activity in the next 30 days; percentile 27.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to a missing permission check on the image preview endpoint, a user with access to the Wagtail admin can preview any image. The existing data of the image object itself is not exposed. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 7.0.8, 7.3.3, 7.4.2. Workarounds For sites that cannot easily upgrade to a current supported version, the vulnerability can be patched by adding the following code to urls.py URL pattern declarations to override the vulnerable view. Acknowledgements Many thanks to @0x1saac and @harshakshit for reporting this issue. For more information If you have any questions or comments about this advisory: Visit Wagtail's support channels Email us at security@wagtail.org (view our security policy for more information).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r6p4-grq7-xm4m
- Revision 1 · created ·
Published from osv record PYSEC-2026-614
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54261 Advisory: Wagtail: Improper permission handling in image preview IDs: CVE-2026-54261, GHSA-r6p4-grq7-xm4m Record: https://patchnext.com/advisories/cve-2026-54261 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 7.4.2, 7.3.3, 7.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected < 7.0.8; >= 7.1, < 7.3.3; >= 7.4, < 7.4.2; fixed in 7.0.8, 7.3.3, 7.4.2 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-614 (OSV record PYSEC-2026-614 lists affected ranges: PyPI wagtail >=0 <7.0.8 (fixed), >=7.1 <7.3.3 (fixed), >=7.4 <7.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-r6p4-grq7-xm4m (GitHub-reviewed advisory GHSA-r6p4-grq7-xm4m lists affected ranges: PyPI wagtail >=0 =7.1 =7.4 <7.4.2) Commands are suggestions: review each one before running it.
Loading voting…