Skip to content

← Actionable
Medium, CVSS 4.3amended

Wagtail: Denial of service via unbounded filter specs in the image preview

CVE-2026-54260GHSA-f2p5-j6fg-5cxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 7.4.2, 7.3.3, 7.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 7.0.8>= 7.1, < 7.3.3>= 7.4, < 7.4.2
    Fixed in
    7.0.8, 7.3.3, 7.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-54260: 0.37% estimated exploitation activity in the next 30 days; percentile 31.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated admin user can trigger expensive rendition processing with purposefully crafted filter specs resulting in potentially service degradation. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 7.0.8, 7.3.3, 7.4.2. Workarounds For sites that cannot easily upgrade to a current supported version, the vulnerability can be patched by adding the following code to urls.py URL pattern declarations to override the vulnerable view. Acknowledgements Many thanks to @0x1saac for reporting this issue. For more information If you have any questions or comments about this advisory: Visit Wagtail's support channels Email us at security@wagtail.org (view our security policy for more information).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f2p5-j6fg-5cxf

  2. Revision 1 · created ·

    Published from osv record PYSEC-2026-613

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54260

Advisory: Wagtail: Denial of service via unbounded filter specs in the image preview
IDs: CVE-2026-54260, GHSA-f2p5-j6fg-5cxf
Record: https://patchnext.com/advisories/cve-2026-54260 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 7.4.2, 7.3.3, 7.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 7.0.8; >= 7.1, < 7.3.3; >= 7.4, < 7.4.2; fixed in 7.0.8, 7.3.3, 7.4.2

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2026-613 (OSV record PYSEC-2026-613 lists affected ranges: PyPI wagtail >=0 <7.0.8 (fixed), >=7.1 <7.3.3 (fixed), >=7.4 <7.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-f2p5-j6fg-5cxf (GitHub-reviewed advisory GHSA-f2p5-j6fg-5cxf lists affected ranges: PyPI wagtail >=0 =7.1 =7.4 <7.4.2)

Commands are suggestions: review each one before running it.

Loading voting…