Electron: Buffer performs incorrect byte length calculations resulting in heap buffer under/overflow
CVE-2026-54257GHSA-q6m5-f73j-m9mc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 42.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- >= 42.3.1, < 42.3.3
- Fixed in
- 42.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6m5-f73j-m9mc lists affected ranges: npm electron >=42.3.1 <42.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q6m5-f73j-m9mc lists affected ranges: npm electron >=42.3.1 <42.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54257: 0.43% estimated exploitation activity in the next 30 days; percentile 37.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Most apps will crash and some may perform incorrect buffer allocations in the Node.js Buffer API resulting in unexpected truncation or allocation. Workarounds No workarounds. Do not use these impacted Electron releases Fixed Versions 42.3.3 For more information If you have any questions or comments about this advisory, email us at security@electronjs.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-q6m5-f73j-m9mc
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-q6m5-f73j-m9mc
- Revision 1 · created ·
Published from ghsa record GHSA-q6m5-f73j-m9mc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54257 Advisory: Electron: Buffer performs incorrect byte length calculations resulting in heap buffer under/overflow IDs: CVE-2026-54257, GHSA-q6m5-f73j-m9mc Record: https://patchnext.com/advisories/cve-2026-54257 (revision 4, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 42.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected >= 42.3.1, < 42.3.3; fixed in 42.3.3 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q6m5-f73j-m9mc (GitHub-reviewed advisory GHSA-q6m5-f73j-m9mc lists affected ranges: npm electron >=42.3.1 <42.3.3) - Verified: https://osv.dev/vulnerability/GHSA-q6m5-f73j-m9mc (OSV record GHSA-q6m5-f73j-m9mc lists affected ranges: npm electron >=42.3.1 <42.3.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…