Skip to content

← Actionable
Medium, CVSS 5.8

K3s: ZIP Archive Path Traversal Vulnerability in etcd Snapshot Decompression

CVE-2026-54250GHSA-jxr7-mqhw-9p98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/k3s-io/k3s 1.35.3, 1.34.6, 1.33.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/k3s-io/k3s

    Affected
    >= 1.35.0-rc1, < 1.35.3>= 1.34.0-rc1, < 1.34.6< 1.33.10
    Fixed in
    1.33.10, 1.34.6, 1.35.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-54250: 0.17% estimated exploitation activity in the next 30 days; percentile 6.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability exists in K3s's etcd snapshot decompression functionality. Zip files containing archive members with maliciously crafted names (e.g., ../../../../etc/password) can be written to arbitrary locations on the filesystem when an administrator restores the archive as a compressed etcd snapshot. Mitigations Enable golang's built-in insecure path protections when restoring snapshots by setting theGODEBUG environment variable: Manually extract the snapshot from the zip archive before restoring it. If the snapshot to be restored does not end with .zip, the vulnerable extraction code will not be executed. Additional Notes Administrators should be aware of the cautions noted in the "Security" section of the documentation on Restoring Snapshots.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jxr7-mqhw-9p98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54250

Advisory: K3s: ZIP Archive Path Traversal Vulnerability in etcd Snapshot Decompression
IDs: CVE-2026-54250, GHSA-jxr7-mqhw-9p98
Record: https://patchnext.com/advisories/cve-2026-54250 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/k3s-io/k3s 1.35.3, 1.34.6, 1.33.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/k3s-io/k3s: affected >= 1.35.0-rc1, < 1.35.3; >= 1.34.0-rc1, < 1.34.6; < 1.33.10; fixed in 1.33.10, 1.34.6, 1.35.3

## Suggested inspection (read-only)
- Go github.com/k3s-io/k3s: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/k3s-io/k3s.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jxr7-mqhw-9p98 (GitHub-reviewed advisory GHSA-jxr7-mqhw-9p98 lists affected ranges: Go github.com/k3s-io/k3s >=1.35.0-rc1 =1.34.0-rc1 =0 <1.33.10)

Commands are suggestions: review each one before running it.

Loading voting…