Skip to content

← Actionable
Medium, CVSS 6.9amended

vLLM: temperature=NaN and temperature=Infinity bypass validation and propagate to GPU kernels

CVE-2026-54235GHSA-7h4p-rffg-7823

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.24.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.8.5, <= 0.23.0
    Fixed in
    0.24.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54235: 0.45% estimated exploitation activity in the next 30 days; percentile 39.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary All temperature validation gates use comparison operators (<, ), which silently evaluate to False for NaN and for positive Infinity in Python's IEEE 754 float semantics. Both values pass every guard and propagate to GPU sampling kernels, where they produce undefined behavior or CUDA errors that can crash the inference worker. Note: -Infinity is correctly caught. Root Cause samplingparams.py:384: samplingparams.py:462: No math.isnan() or math.isinf() check exists anywhere in samplingparams.py. Python semantics (verified): float('nan') < 0.0 → False, float('inf') < 0.0 → False. Impact Crash of inference worker on GPU kernel execution with NaN/Inf softmax input, degrading service for all concurrent users. Remediation Add math.isfinite(self.temperature) check in verifyargs(). Reject non-finite float values with a 400 error. Fix A fix for this vulnerability was merged here: https://github.com/vllm-project/vllm/pull/45116

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7h4p-rffg-7823

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7h4p-rffg-7823

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54235

Advisory: vLLM: temperature=NaN and temperature=Infinity bypass validation and propagate to GPU kernels
IDs: CVE-2026-54235, GHSA-7h4p-rffg-7823
Record: https://patchnext.com/advisories/cve-2026-54235 (revision 3, source checked 26 Oct 2026, 13:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.24.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.8.5, <= 0.23.0; fixed in 0.24.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7h4p-rffg-7823 (OSV record GHSA-7h4p-rffg-7823 lists affected ranges: PyPI vllm >=0.8.5 <0.24.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7h4p-rffg-7823 (GitHub-reviewed advisory GHSA-7h4p-rffg-7823 lists affected ranges: PyPI vllm >=0.8.5 <=0.23.0)

Commands are suggestions: review each one before running it.

Loading voting…