vLLM has Remote DoS via Invalid Recovered Token Reinjection
CVE-2026-54234GHSA-8wr5-jm2h-8r4f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.17.1, < 0.24.0
- Fixed in
- 0.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8wr5-jm2h-8r4f lists affected ranges: PyPI vllm >=0.17.1 <0.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wr5-jm2h-8r4f lists affected ranges: PyPI vllm >=0.17.1 <0.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-54234: 0.62% estimated exploitation activity in the next 30 days; percentile 49.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A frontend-legal multi-request speculative workload can make vLLM produce an out-of-vocabulary recovered token equal to vocabsize, convert that value to -1 when choosing the next live token for a request, and then feed that -1 back into the next drafter input ids. On Qwen3 GPTQ this reaches the worker-side drafting / attention path and crashes the engine with a GPU device-side assert. The same issue is reachable through the public gRPC request surface by sending a specific overlapping Generate / Abort sequence. Impact - A remote client that can send public gRPC generation requests can crash the shared vLLM engine worker - The triggering request sequence aborts concurrent requests and prevents later requests from completing until the worker is restarted - In shared deployments, this is a service-wide denial of service for other clients, not just a failure isolated to the attacking requests - The failure is reproducible, so repeated request sequences can sustain the outage…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8wr5-jm2h-8r4f
- Revision 1 · created ·
Published from osv record GHSA-8wr5-jm2h-8r4f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54234 Advisory: vLLM has Remote DoS via Invalid Recovered Token Reinjection IDs: CVE-2026-54234, GHSA-8wr5-jm2h-8r4f Record: https://patchnext.com/advisories/cve-2026-54234 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.17.1, < 0.24.0; fixed in 0.24.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8wr5-jm2h-8r4f (OSV record GHSA-8wr5-jm2h-8r4f lists affected ranges: PyPI vllm >=0.17.1 <0.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8wr5-jm2h-8r4f (GitHub-reviewed advisory GHSA-8wr5-jm2h-8r4f lists affected ranges: PyPI vllm >=0.17.1 <0.24.0) Commands are suggestions: review each one before running it.
Loading voting…