Skip to content

← Actionable
High, CVSS 8.1amended

Laravel Backpack CRUD: OS command injection in Stats::makeCurlRequest via attacker-controlled Host header (pre-auth)

CVE-2026-54182GHSA-mrc5-3mm3-45c5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.36, 6.8.13, 5.6.2, 4.1.72), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist backpack/crud

    Affected
    >= 4.1.0, < 4.1.72>= 5.0.0, < 5.6.2>= 6.0.0, < 6.8.13>= 7.0.0, < 7.0.36
    Fixed in
    4.1.72, 7.0.36, 6.8.13, 5.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-54182: 0.78% estimated exploitation activity in the next 30 days; percentile 56.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Backpack\CRUD\Stats::makeCurlRequest builds a shell command using unescaped input that originates from the HTTP Host header, then passes it to exec(). A specially crafted Host header can break out of the shell argument and cause the server to execute arbitrary OS commands as the web user. The vulnerable code path is reached from BackpackServiceProvider::boot() on every HTTP request in production when exec() and curl are available. A 1-in-100 random gate is the only guard — an attacker can reliably trigger it by retrying. Severity High — CVSS 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H Attack Complexity is rated High because default nginx and Apache configurations typically strip or reject malformed Host headers before they reach PHP, and exec() is often disabled for web processes in hardened environments. Both mitigations must be absent for exploitation. Impact A successful exploit yields OS command execution as the web server user (www-data, nginx, etc.), giving an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mrc5-3mm3-45c5

  2. Revision 1 · created ·

    Published from osv record GHSA-mrc5-3mm3-45c5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54182

Advisory: Laravel Backpack CRUD: OS command injection in Stats::makeCurlRequest via attacker-controlled Host header (pre-auth)
IDs: CVE-2026-54182, GHSA-mrc5-3mm3-45c5
Record: https://patchnext.com/advisories/cve-2026-54182 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.36, 6.8.13, 5.6.2, 4.1.72. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/crud: affected >= 4.1.0, < 4.1.72; >= 5.0.0, < 5.6.2; >= 6.0.0, < 6.8.13; >= 7.0.0, < 7.0.36; fixed in 4.1.72, 7.0.36, 6.8.13, 5.6.2

## Suggested inspection (read-only)
- Packagist backpack/crud: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/crud.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mrc5-3mm3-45c5 (OSV record GHSA-mrc5-3mm3-45c5 lists affected ranges: Packagist backpack/crud >=4.1.0 =5.0.0 =6.0.0 =7.0.0 <7.0.36 (fixed))
- Verified: https://github.com/advisories/GHSA-mrc5-3mm3-45c5 (GitHub-reviewed advisory GHSA-mrc5-3mm3-45c5 lists affected ranges: Packagist backpack/crud >=4.1.0 =5.0.0 =6.0.0 =7.0.0 <7.0.36)

Commands are suggestions: review each one before running it.

Loading voting…