Skip to content

← Actionable
Medium, CVSS 5.4amended

Laravel Backpack CRUD: Stored XSS in the color column — the @if($column['escaped']) branches are inverted

CVE-2026-54181GHSA-mmg4-322v-6jvc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.38, 6.8.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist backpack/crud

    Affected
    >= 6.0.0, < 6.8.14>= 7.0.0, < 7.0.38
    Fixed in
    7.0.38, 6.8.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-54181: 0.31% estimated exploitation activity in the next 30 days; percentile 24.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Blade template for the color column type (src/resources/views/crud/columns/color.blade.php) has its escaped/unescaped rendering branches inverted relative to every other column template in the library. Because $column['escaped'] defaults to true, values stored in color columns are rendered unescaped by default, enabling Stored XSS if column values are not validated before storage. Details All other column templates in src/resources/views/crud/columns/ follow the convention: - $column['escaped'] == true → {{ $column['text'] }} (HTML-escaped) - $column['escaped'] == false → {!! $column['text'] !!} (raw) The color template has these branches swapped. An attacker who can write an arbitrary string to a color-typed column can inject JavaScript that executes in the browser of any user who views the list — including administrators — with access to their session cookies and CSRF tokens. Impact Stored XSS with scope change (attacker context runs in victim's browser). Highest-risk…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mmg4-322v-6jvc

  2. Revision 1 · created ·

    Published from osv record GHSA-mmg4-322v-6jvc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54181

Advisory: Laravel Backpack CRUD: Stored XSS in the color column — the `@if($column['escaped'])` branches are inverted
IDs: CVE-2026-54181, GHSA-mmg4-322v-6jvc
Record: https://patchnext.com/advisories/cve-2026-54181 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.38, 6.8.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/crud: affected >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38; fixed in 7.0.38, 6.8.14

## Suggested inspection (read-only)
- Packagist backpack/crud: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/crud.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mmg4-322v-6jvc (OSV record GHSA-mmg4-322v-6jvc lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38 (fixed))
- Verified: https://github.com/advisories/GHSA-mmg4-322v-6jvc (GitHub-reviewed advisory GHSA-mmg4-322v-6jvc lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38)

Commands are suggestions: review each one before running it.

Loading voting…