Skip to content

← Actionable
High, CVSS 7.6amended

Laravel Backpack CRUD: CRUD panel query scopes are not enforced on Update, Delete, and Reorder (cross-tenant IDOR)

CVE-2026-54180GHSA-vgmv-8xjc-6rch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.38, 6.8.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist backpack/crud

    Affected
    >= 6.0.0, < 6.8.14>= 7.0.0, < 7.0.38
    Fixed in
    7.0.38, 6.8.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
EPSS
  • CVE-2026-54180: 0.46% estimated exploitation activity in the next 30 days; percentile 40.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Backpack CRUD's list and read operations correctly apply any query scopes registered via addClause() / addBaseClause() (e.g. tenant isolation, user ownership). However, the Update, Delete, and Reorder operations bypassed these scopes, fetching records directly from the unscoped model query. An authenticated user who knows or can guess a record's primary key could therefore update, delete, or reorder records that should be invisible to them — a classic IDOR on write paths. Applications that rely on addBaseClause for row-level access control (multi-tenancy, per-user data isolation) are affected. Impact Any Backpack CRUD panel that uses addBaseClause or addClause to restrict which rows a user may access is affected on its write operations. An authenticated low-privilege user can modify or delete records belonging to other tenants / users. Patches Apply the fixed release for your major version: - v6: upgrade to 6.8.14 or later - v7: upgrade to 7.0.38 or later The fix ensures…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vgmv-8xjc-6rch

  2. Revision 1 · created ·

    Published from osv record GHSA-vgmv-8xjc-6rch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54180

Advisory: Laravel Backpack CRUD: CRUD panel query scopes are not enforced on Update, Delete, and Reorder (cross-tenant IDOR)
IDs: CVE-2026-54180, GHSA-vgmv-8xjc-6rch
Record: https://patchnext.com/advisories/cve-2026-54180 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.38, 6.8.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/crud: affected >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38; fixed in 7.0.38, 6.8.14

## Suggested inspection (read-only)
- Packagist backpack/crud: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/crud.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vgmv-8xjc-6rch (OSV record GHSA-vgmv-8xjc-6rch lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38 (fixed))
- Verified: https://github.com/advisories/GHSA-vgmv-8xjc-6rch (GitHub-reviewed advisory GHSA-vgmv-8xjc-6rch lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38)

Commands are suggestions: review each one before running it.

Loading voting…