Skip to content

← Actionable
Medium, CVSS 4.4amended

Laravel Backpack CRUD: SingleBase64Image accepts any base64 payload behind a data:image prefix — SVG-with-script lands on the public disk

CVE-2026-54179GHSA-8hw4-7qjr-3wxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.38, 6.8.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist backpack/crud

    Affected
    >= 6.0.0, < 6.8.14>= 7.0.0, < 7.0.38
    Fixed in
    7.0.38, 6.8.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-54179: 0.26% estimated exploitation activity in the next 30 days; percentile 17.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SingleBase64Image::uploadFiles — the uploader bound to image-typed fields via withFiles() — only verifies that the submitted value starts with the string data:image. The MIME subtype and the base64-decoded bytes are never inspected or validated. A related bug in FileNameGenerator causes the stored file to receive an extensionless filename, because mimecontenttype() returns false when given a data URI instead of a filesystem path. The combination allows an authenticated admin to store a file of arbitrary type on the configured disk under a name without a recognizable extension. Details The stored filename ends with a trailing dot and no extension. Impact An authenticated admin submitting a malicious payload to a Backpack image field stored with withFiles() can write arbitrary file content to the configured storage disk. Depending on server configuration and how stored files are served, this may lead to stored XSS or other unintended behavior when the file is later accessed.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8hw4-7qjr-3wxg

  2. Revision 1 · created ·

    Published from osv record GHSA-8hw4-7qjr-3wxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54179

Advisory: Laravel Backpack CRUD: SingleBase64Image accepts any base64 payload behind a `data:image` prefix — SVG-with-script lands on the public disk
IDs: CVE-2026-54179, GHSA-8hw4-7qjr-3wxg
Record: https://patchnext.com/advisories/cve-2026-54179 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.38, 6.8.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/crud: affected >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38; fixed in 7.0.38, 6.8.14

## Suggested inspection (read-only)
- Packagist backpack/crud: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/crud.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8hw4-7qjr-3wxg (OSV record GHSA-8hw4-7qjr-3wxg lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38 (fixed))
- Verified: https://github.com/advisories/GHSA-8hw4-7qjr-3wxg (GitHub-reviewed advisory GHSA-8hw4-7qjr-3wxg lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38)

Commands are suggestions: review each one before running it.

Loading voting…