Skip to content

← Actionable
High, CVSS 8.1

Laravel Backpack CRUD: Arbitrary file deletion via attacker-controlled clear_ [] in HasUploadFields::uploadMultipleFilesToDisk

CVE-2026-54178GHSA-8xjm-wqrp-2f25

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist backpack/crud

    Affected
    >= 5.0.0>= 6.0.0, < 6.8.12>= 7.0.0, < 7.0.35
    Fixed in
    6.8.12, 7.0.35

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-54178: 0.56% estimated exploitation activity in the next 30 days; percentile 46.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `HasUploadFields::uploadMultipleFilesToDisk` (in `src/app/Models/Traits/HasUploadFields.php`) reads file paths from the `clear_ []` request input and deletes them from the configured storage disk without verifying that the paths belong to the current model record. An authenticated user with Update access on any CRUD that wires `uploadMultipleFilesToDisk` as a model mutator (the pattern documented in the v5.x `upload_multiple` field guide) can supply arbitrary disk-relative paths in `clear_ []` to delete files that were never associated with the record they are editing. The safe pattern already exists in the codebase: `src/app/Library/Uploaders/MultipleFiles.php` intersects the requested deletions against the files currently stored in the database column before calling `Storage::disk()->delete()`. The trait method lacks that intersection.

Affected code - `src/app/Models/Traits/HasUploadFields.php` — `uploadMultipleFilesToDisk` (primary sink) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-8xjm-wqrp-2f25

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54178

Advisory: Laravel Backpack CRUD: Arbitrary file deletion via attacker-controlled clear_ [] in HasUploadFields::uploadMultipleFilesToDisk
IDs: CVE-2026-54178, GHSA-8xjm-wqrp-2f25
Record: https://patchnext.com/advisories/cve-2026-54178 (revision 1, source checked 23 Oct 2026, 22:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: . A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/crud: affected >= 5.0.0; >= 6.0.0, < 6.8.12; >= 7.0.0, < 7.0.35; fixed in 6.8.12, 7.0.35

## Suggested inspection (read-only)
- Packagist backpack/crud: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/crud.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8xjm-wqrp-2f25 (OSV record GHSA-8xjm-wqrp-2f25 lists affected ranges: Packagist backpack/crud >=5.0.0, >=6.0.0 =7.0.0 <7.0.35 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…