Skip to content

← Actionable
Medium, CVSS 6.6amended

Laravel Backpack CRUD: HasUploadFields keeps the attacker-supplied file extension — public-disk uploads of shell.php reach the webserver

CVE-2026-54177GHSA-8q2w-pv9p-mjvc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.38, 6.8.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist backpack/crud

    Affected
    >= 6.0.0, < 6.8.14>= 7.0.0, < 7.0.38
    Fixed in
    7.0.38, 6.8.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-54177: 0.93% estimated exploitation activity in the next 30 days; percentile 60.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary HasUploadFields (used via CrudTrait on Backpack-managed models) and the withFiles() uploader preserve the client-supplied file extension without validation. On installations using a public disk with php artisan storage:link, this allows an authenticated administrator to upload a file with a server-executable extension that the web server will pass to the PHP interpreter - if no MIME or other type of upload validation is present. Details The uploadFileToDisk and uploadMultipleFilesToDisk methods hash the filename stem but write the client-supplied extension to disk verbatim — no allowlist, blocklist, or MIME check is applied inside the trait itself. The newer withFiles() path (via FileNameGenerator) resolves the extension from the file's MIME type rather than the client filename, but also does not block server-executable types. Applications that follow the Backpack quickstart without adding explicit mimes: or mimetypes: validation rules in their form requests are affected.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8q2w-pv9p-mjvc

  2. Revision 1 · created ·

    Published from osv record GHSA-8q2w-pv9p-mjvc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54177

Advisory: Laravel Backpack CRUD: HasUploadFields keeps the attacker-supplied file extension — public-disk uploads of `shell.php` reach the webserver
IDs: CVE-2026-54177, GHSA-8q2w-pv9p-mjvc
Record: https://patchnext.com/advisories/cve-2026-54177 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.38, 6.8.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/crud: affected >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38; fixed in 7.0.38, 6.8.14

## Suggested inspection (read-only)
- Packagist backpack/crud: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/crud.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8q2w-pv9p-mjvc (OSV record GHSA-8q2w-pv9p-mjvc lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38 (fixed))
- Verified: https://github.com/advisories/GHSA-8q2w-pv9p-mjvc (GitHub-reviewed advisory GHSA-8q2w-pv9p-mjvc lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38)

Commands are suggestions: review each one before running it.

Loading voting…