Laravel Backpack CRUD: MyAccountController allows changing the login email without a current-password check
CVE-2026-54176GHSA-9fw9-8c49-qch8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.38, 6.8.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist backpack/crud
- Affected
- >= 6.0.0, < 6.8.14>= 7.0.0, < 7.0.38
- Fixed in
- 7.0.38, 6.8.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9fw9-8c49-qch8 lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9fw9-8c49-qch8 lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-54176: 0.65% estimated exploitation activity in the next 30 days; percentile 51.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary MyAccountController::postAccountInfoForm allows an authenticated user to update the authentication column (default: email) without verifying their current password. Because email is the account-recovery anchor, this enables account takeover after the attacker's session ends: the new email address can be used to request a password reset from outside the system. The password-change endpoint in the same controller correctly requires oldpassword verification, so the gap is asymmetric. Details The postAccountInfoForm action passes $request-validated() directly to $user-update(). The AccountInfoRequest whitelists the authentication column (email by default) with no ownership challenge. Contrast this with ChangePasswordRequest, which uses Hash::check against the stored password before allowing any change. Scenarios where this is exploitable include: - A brief unauthorized session (e.g. unattended workstation, XSS in the admin panel) - An insider/offboarding case where a departing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9fw9-8c49-qch8
- Revision 1 · created ·
Published from osv record GHSA-9fw9-8c49-qch8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54176 Advisory: Laravel Backpack CRUD: MyAccountController allows changing the login email without a current-password check IDs: CVE-2026-54176, GHSA-9fw9-8c49-qch8 Record: https://patchnext.com/advisories/cve-2026-54176 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.38, 6.8.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist backpack/crud: affected >= 6.0.0, < 6.8.14; >= 7.0.0, < 7.0.38; fixed in 7.0.38, 6.8.14 ## Suggested inspection (read-only) - Packagist backpack/crud: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on backpack/crud. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9fw9-8c49-qch8 (OSV record GHSA-9fw9-8c49-qch8 lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38 (fixed)) - Verified: https://github.com/advisories/GHSA-9fw9-8c49-qch8 (GitHub-reviewed advisory GHSA-9fw9-8c49-qch8 lists affected ranges: Packagist backpack/crud >=6.0.0 =7.0.0 <7.0.38) Commands are suggestions: review each one before running it.
Loading voting…