Pipelines-as-Code GitHub App token request can be redirected via untrusted Enterprise Host header
CVE-2026-54167GHSA-f5f4-3hh4-f54m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openshift-pipelines/pipelines-as-code 0.48.0, 0.42.1, 0.39.6, 0.37.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/openshift-pipelines/pipelines-as-code
- Affected
- >= 0.43.0, < 0.48.0>= 0.40.0, < 0.42.1>= 0.38.0, < 0.39.6< 0.37.8
- Fixed in
- 0.48.0, 0.42.1, 0.37.8, 0.39.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f5f4-3hh4-f54m lists affected ranges: Go github.com/openshift-pipelines/pipelines-as-code >=0.43.0 =0.40.0 =0.38.0 =0 <0.37.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6266 lists affected ranges: Go github.com/openshift-pipelines/pipelines-as-code >=0 =0.38.0 =0.40.0 =0.43.0 <0.48.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5f4-3hh4-f54m lists affected ranges: Go github.com/openshift-pipelines/pipelines-as-code >=0.43.0 =0.40.0 =0.38.0 =0 <0.37.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-54167: 0.27% estimated exploitation activity in the next 30 days; percentile 19.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Pipelines-as-Code installations using the GitHub App provider are vulnerable to GitHub App credential exfiltration through the webhook endpoint. Affected versions accepted the `X-GitHub-Enterprise-Host` request header as the GitHub Enterprise API host during GitHub App token generation. For GitHub webhook events containing an `installation.id`, Pipelines-as-Code generated a GitHub App JWT and requested an installation access token before validating the webhook signature or checking that the Enterprise host matched the repository URL in the signed payload. An attacker who can reach the Pipelines-as-Code webhook endpoint can send a crafted GitHub webhook payload containing an installation ID and set `X-GitHub-Enterprise-Host` to an attacker-controlled host. During token generation, the controller signs a GitHub App JWT locally and sends it to the selected API host. This can disclose the GitHub App JWT to the attacker-controlled service, allowing the attacker to attempt to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-f5f4-3hh4-f54m
- Revision 4 · amended ·
Amended from ghsa record GHSA-f5f4-3hh4-f54m
- Revision 3 · amended ·
Amended from ghsa record GHSA-f5f4-3hh4-f54m
- Revision 2 · amended ·
Amended from osv record GO-2026-6266
- Revision 1 · created ·
Published from osv record GHSA-f5f4-3hh4-f54m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54167 Advisory: Pipelines-as-Code GitHub App token request can be redirected via untrusted Enterprise Host header IDs: CVE-2026-54167, GHSA-f5f4-3hh4-f54m Record: https://patchnext.com/advisories/cve-2026-54167 (revision 5, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openshift-pipelines/pipelines-as-code 0.48.0, 0.42.1, 0.39.6, 0.37.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openshift-pipelines/pipelines-as-code: affected >= 0.43.0, < 0.48.0; >= 0.40.0, < 0.42.1; >= 0.38.0, < 0.39.6; < 0.37.8; fixed in 0.48.0, 0.42.1, 0.37.8, 0.39.6 ## Suggested inspection (read-only) - Go github.com/openshift-pipelines/pipelines-as-code: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openshift-pipelines/pipelines-as-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f5f4-3hh4-f54m (OSV record GHSA-f5f4-3hh4-f54m lists affected ranges: Go github.com/openshift-pipelines/pipelines-as-code >=0.43.0 =0.40.0 =0.38.0 =0 <0.37.8 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6266 (OSV record GO-2026-6266 lists affected ranges: Go github.com/openshift-pipelines/pipelines-as-code >=0 =0.38.0 =0.40.0 =0.43.0 <0.48.0 (fixed)) - Verified: https://github.com/advisories/GHSA-f5f4-3hh4-f54m (GitHub-reviewed advisory GHSA-f5f4-3hh4-f54m lists affected ranges: Go github.com/openshift-pipelines/pipelines-as-code >=0.43.0 =0.40.0 =0.38.0 =0 <0.37.8) Commands are suggestions: review each one before running it.
Loading voting…