API Platform Core: Relation IRIs are not type-checked: a related resource can be denormalised as the wrong resource type (type confusion)
CVE-2026-54164GHSA-9rjg-x2p2-h68h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (api-platform/core 4.3.12, 4.2.26, 4.1.30), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist api-platform/core
- Affected
- < 4.1.30>= 4.2.0, < 4.2.26>= 4.3.0, < 4.3.12
- Fixed in
- 4.1.30, 4.3.12, 4.2.26
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9rjg-x2p2-h68h lists affected ranges: Packagist api-platform/core >=0 =4.2.0 =4.3.0 <4.3.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9rjg-x2p2-h68h lists affected ranges: Packagist api-platform/core >=0 =4.2.0 =4.3.0 <4.3.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-54164: 0.34% estimated exploitation activity in the next 30 days; percentile 27.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The API Platform serializer's AbstractItemNormalizer does not validate the resource type returned when resolving relation IRIs, allowing type confusion where a resource of an unintended type can be silently assigned to a relation property. Impact An attacker who can submit write requests (POST/PUT/PATCH) to an API Platform endpoint with writable relations can supply a relation IRI pointing to a resource of a different type than the relation's declared class. Because getResourceFromIri() does not pass an $operation to IriConverter::getResourceFromIri(), the isa type guard at IriConverter.php:86 is skipped. For untyped relation properties (legacy @var-only style), the wrong-typed object is silently assigned, corrupting invariants and potentially feeding downstream logic that assumes the declared type (CWE-843). For typed properties (modern PHP 8.x), the substitution is blocked by Symfony's PropertyAccessor with an InvalidTypeException. Affected versions - api-platform/core <…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9rjg-x2p2-h68h
- Revision 1 · created ·
Published from osv record GHSA-9rjg-x2p2-h68h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54164 Advisory: API Platform Core: Relation IRIs are not type-checked: a related resource can be denormalised as the wrong resource type (type confusion) IDs: CVE-2026-54164, GHSA-9rjg-x2p2-h68h Record: https://patchnext.com/advisories/cve-2026-54164 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: api-platform/core 4.3.12, 4.2.26, 4.1.30. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist api-platform/core: affected < 4.1.30; >= 4.2.0, < 4.2.26; >= 4.3.0, < 4.3.12; fixed in 4.1.30, 4.3.12, 4.2.26 ## Suggested inspection (read-only) - Packagist api-platform/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on api-platform/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9rjg-x2p2-h68h (OSV record GHSA-9rjg-x2p2-h68h lists affected ranges: Packagist api-platform/core >=0 =4.2.0 =4.3.0 <4.3.12 (fixed)) - Verified: https://github.com/advisories/GHSA-9rjg-x2p2-h68h (GitHub-reviewed advisory GHSA-9rjg-x2p2-h68h lists affected ranges: Packagist api-platform/core >=0 =4.2.0 =4.3.0 <4.3.12) Commands are suggestions: review each one before running it.
Loading voting…