Skip to content

← Actionable
Medium, CVSS 4.7amended

Ember has unneutralized terminal escape/control sequences from Caddy logs injected into the operator's TUI

CVE-2026-54162GHSA-x3g7-qrwc-f6c5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/alexandre-daubois/ember 1.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
EPSS
  • CVE-2026-54162: 0.25% estimated exploitation activity in the next 30 days; percentile 16.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Ember's interactive TUI renders fields taken from the monitored Caddy server's access logs — most notably the request URI — straight to the operator's terminal without neutralising terminal escape or control sequences (CWE-150). Those log fields are populated from arbitrary, unauthenticated HTTP requests, so any remote client can embed ANSI/OSC/CSI control bytes that the operator's terminal emulator interprets when the log row is displayed. The bytes survive the whole pipeline: Caddy escapes them into its JSON access log as unicode escapes, ember's ParseLogLine decodes them back to raw 0x1b/0x07 bytes, and the row formatters concatenate them into the bubbletea View() output with no encoding before they reach os.Stdout. Impact An unauthenticated, remote attacker who can send HTTP requests to the Caddy server that ember monitors can inject terminal escape sequences into the operator's TUI. The trigger is a single ordinary HTTP request with control bytes in the request target.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x3g7-qrwc-f6c5

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6270

  3. Revision 1 · created ·

    Published from osv record GHSA-x3g7-qrwc-f6c5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54162

Advisory: Ember has unneutralized terminal escape/control sequences from Caddy logs injected into the operator's TUI
IDs: CVE-2026-54162, GHSA-x3g7-qrwc-f6c5
Record: https://patchnext.com/advisories/cve-2026-54162 (revision 3, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/alexandre-daubois/ember 1.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/alexandre-daubois/ember: affected < 1.4.2; fixed in 1.4.2

## Suggested inspection (read-only)
- Go github.com/alexandre-daubois/ember: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/alexandre-daubois/ember.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3g7-qrwc-f6c5 (OSV record GHSA-x3g7-qrwc-f6c5 lists affected ranges: Go github.com/alexandre-daubois/ember >=0 <1.4.2 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6270 (OSV record GO-2026-6270 lists affected ranges: Go github.com/alexandre-daubois/ember >=0 <1.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-x3g7-qrwc-f6c5 (GitHub-reviewed advisory GHSA-x3g7-qrwc-f6c5 lists affected ranges: Go github.com/alexandre-daubois/ember >=0 <1.4.2)

Commands are suggestions: review each one before running it.

Loading voting…