LobeHub: Unauthenticated SSRF in /webapi/proxy
CVE-2026-54157GHSA-xmwj-c75x-6346
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/lobehub 2.1.57), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @lobehub/lobehub
- Affected
- <= 2.1.56
- Fixed in
- 2.1.57
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xmwj-c75x-6346 lists affected ranges: npm @lobehub/lobehub >=0 <=2.1.56
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xmwj-c75x-6346 lists affected ranges: npm @lobehub/lobehub >=0 <2.1.57 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:H
- EPSS
- CVE-2026-54157: 1.83% estimated exploitation activity in the next 30 days; percentile 78.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unauthenticated SSRF in /webapi/proxy allows anyone to proxy requests and inject cookies on lobehub.com Summary The /webapi/proxy endpoint on app.lobehub.com accepts a URL in the POST body and fetches it server-side without any authentication. This is the same proxy code that was vulnerable in CVE-2024-32964, where /api/proxy was fixed by adding auth middleware. The /webapi/proxy route was never secured — it is the only webapi route missing the checkAuth() wrapper. An attacker can use this to make arbitrary outbound requests from LobeHub's infrastructure, leak Vercel deployment details, and inject cookies on the lobehub.com domain through reflected Set-Cookie headers. Vulnerability Details Type: Server-Side Request Forgery (CWE-918) Affected Endpoint: POST /webapi/proxy Vulnerable File: src/app/(backend)/webapi/proxy/route.ts The route handler reads a URL from the request body and passes it to ssrfSafeFetch() without calling checkAuth() first. Every other webapi route (/webapi/chat/,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xmwj-c75x-6346
- Revision 2 · amended ·
Amended from osv record GHSA-xmwj-c75x-6346
- Revision 1 · created ·
Published from ghsa record GHSA-xmwj-c75x-6346
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54157 Advisory: LobeHub: Unauthenticated SSRF in `/webapi/proxy` IDs: CVE-2026-54157, GHSA-xmwj-c75x-6346 Record: https://patchnext.com/advisories/cve-2026-54157 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @lobehub/lobehub 2.1.57. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @lobehub/lobehub: affected <= 2.1.56; fixed in 2.1.57 ## Suggested inspection (read-only) - `npm ls @lobehub/lobehub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @lobehub/lobehub. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xmwj-c75x-6346 (GitHub-reviewed advisory GHSA-xmwj-c75x-6346 lists affected ranges: npm @lobehub/lobehub >=0 <=2.1.56) - Verified: https://osv.dev/vulnerability/GHSA-xmwj-c75x-6346 (OSV record GHSA-xmwj-c75x-6346 lists affected ranges: npm @lobehub/lobehub >=0 <2.1.57 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…