Skip to content

← Actionable
Medium, CVSS 6.9amended

next-video: Unauthenticated arbitrary file read via /api/video request handler

CVE-2026-54150GHSA-2p39-2jf3-fv2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-video 2.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54150: 0.42% estimated exploitation activity in the next 30 days; percentile 36.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The HTTP route handler exported by next-video/request-handler — which the README instructs consumers to mount at /api/video — allows an unauthenticated remote attacker to read arbitrary .json files from the production filesystem of any application following the documented setup. The handler's GET endpoint accepts a url query parameter and uses it to locate and serve a JSON asset descriptor from disk. The only guard between "remote URL" and "local file path" is a regex check for ^https?://. Any value that does not match that prefix is treated as a local path, .json is appended, and the file is read with fs.readFile and returned in the HTTP response — with no authentication, no path canonicalization, and no traversal guard. On a typical Next.js deployment this exposes, at minimum: - The Next.js Server Actions AES encryption key (.next/server/server-reference-manifest.json) - The Next.js Preview/Draft Mode keys (previewModeId, previewModeSigningKey, previewModeEncryptionKey) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2p39-2jf3-fv2q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2p39-2jf3-fv2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54150

Advisory: next-video: Unauthenticated arbitrary file read via /api/video request handler
IDs: CVE-2026-54150, GHSA-2p39-2jf3-fv2q
Record: https://patchnext.com/advisories/cve-2026-54150 (revision 3, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next-video 2.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next-video: affected <= 2.8.0; fixed in 2.8.1

## Suggested inspection (read-only)
- `npm ls next-video --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next-video.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2p39-2jf3-fv2q (OSV record GHSA-2p39-2jf3-fv2q lists affected ranges: npm next-video >=0 <2.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2p39-2jf3-fv2q (GitHub-reviewed advisory GHSA-2p39-2jf3-fv2q lists affected ranges: npm next-video >=0 <=2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…