http4k: DigestAuthProvider.verify did not bind to request URI
CVE-2026-54148GHSA-p28p-j94q-pg32
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.http4k:http4k-security-digest 6.50.0.0, 5.42.0.0, 4.51.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.http4k:http4k-security-digest
- Affected
- >= 6.0.0.0, < 6.50.0.0>= 5.0.0.0, < 5.42.0.0>= 4.0.0.0, < 4.51.0.0
- Fixed in
- 5.42.0.0, 6.50.0.0, 4.51.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p28p-j94q-pg32 lists affected ranges: Maven org.http4k:http4k-security-digest >=6.0.0.0 =5.0.0.0 =4.0.0.0 <4.51.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p28p-j94q-pg32 lists affected ranges: Maven org.http4k:http4k-security-digest >=6.0.0.0 =5.0.0.0 =4.0.0.0 <4.51.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-54148: 0.58% estimated exploitation activity in the next 30 days; percentile 47.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An issue in DigestAuthProvider.verify: The uri parameter in the client's Authorization: Digest … response was not checked against the actual request URL. A captured Digest authentication response could be replayed against any other URL served by the same realm, breaking the per-request-URL binding the Digest scheme assumes. Who is affected: any application using http4k-security-digest for HTTP Digest authentication. The bug has been present since DigestAuthProvider was introduced (commit 8a52b615b1, 2021). Patches | Line | Fixed in | Edition | |------|----------|---------| | v6.x (Community) | 6.50.0.0 | Community | | v5.x (LTS) | 5.42.0.0 | Enterprise — contact enterprise@http4k.org (if Digest auth is present in your v5.x line) | | v4.x (LTS) | 4.51.0.0 | Enterprise — contact enterprise@http4k.org (if Digest auth is present in your v4.x line) | The fix: - Rejects credentials whose uri parameter does not match the request URL. Workarounds For deployments that cannot upgrade…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p28p-j94q-pg32
- Revision 1 · created ·
Published from osv record GHSA-p28p-j94q-pg32
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54148 Advisory: http4k: `DigestAuthProvider.verify` did not bind to request URI IDs: CVE-2026-54148, GHSA-p28p-j94q-pg32 Record: https://patchnext.com/advisories/cve-2026-54148 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.http4k:http4k-security-digest 6.50.0.0, 5.42.0.0, 4.51.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.http4k:http4k-security-digest: affected >= 6.0.0.0, < 6.50.0.0; >= 5.0.0.0, < 5.42.0.0; >= 4.0.0.0, < 4.51.0.0; fixed in 5.42.0.0, 6.50.0.0, 4.51.0.0 ## Suggested inspection (read-only) - Maven org.http4k:http4k-security-digest: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.http4k:http4k-security-digest. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p28p-j94q-pg32 (OSV record GHSA-p28p-j94q-pg32 lists affected ranges: Maven org.http4k:http4k-security-digest >=6.0.0.0 =5.0.0.0 =4.0.0.0 <4.51.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-p28p-j94q-pg32 (GitHub-reviewed advisory GHSA-p28p-j94q-pg32 lists affected ranges: Maven org.http4k:http4k-security-digest >=6.0.0.0 =5.0.0.0 =4.0.0.0 <4.51.0.0) Commands are suggestions: review each one before running it.
Loading voting…