Skip to content

← Actionable
Medium, CVSS 6.5

http4k: DigestAuthProvider.verify ignored configured algorithm and did not bind to request URI

CVE-2026-54147GHSA-vxxm-wwqh-mh47

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-54147: 0.26% estimated exploitation activity in the next 30 days; percentile 17.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An issue in DigestAuthProvider.verify: Algorithm silently forced to MD5. The configured algorithm parameter was ignored — every verification used MD5 regardless of configuration. Deployments believing they were running SHA-256 Digest auth were silently inheriting MD5's collision weaknesses, including documented attack paths against Digest schemes that rely on the hash being collision-resistant. Who is affected: any application using http4k-security-digest for HTTP Digest authentication. The bug has been present since DigestAuthProvider was introduced (commit 8a52b615b1, 2021). Patches | Line | Fixed in | Edition | |------|----------|---------| | v6.x (Community) | 6.50.0.0 | Community | | v5.x (LTS) | 5.42.0.0 | Enterprise — contact enterprise@http4k.org (if Digest auth is present in your v5.x line) | | v4.x (LTS) | 4.51.0.0 | Enterprise — contact enterprise@http4k.org (if Digest auth is present in your v4.x line) | The fix: - Hashes with the configured algorithm instead of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vxxm-wwqh-mh47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54147

Advisory: http4k: `DigestAuthProvider.verify` ignored configured algorithm and did not bind to request URI
IDs: CVE-2026-54147, GHSA-vxxm-wwqh-mh47
Record: https://patchnext.com/advisories/cve-2026-54147 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.http4k:http4k-security-digest 6.50.0.0, 5.42.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.http4k:http4k-security-digest: affected >= 5.0.0.0, < 5.42.0.0; <= 4.48.2.0; >= 6.0.0.0, < 6.50.0.0; fixed in 5.42.0.0, 6.50.0.0

## Suggested inspection (read-only)
- Maven org.http4k:http4k-security-digest: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.http4k:http4k-security-digest.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vxxm-wwqh-mh47 (GitHub-reviewed advisory GHSA-vxxm-wwqh-mh47 lists affected ranges: Maven org.http4k:http4k-security-digest >=5.0.0.0 =0 =6.0.0.0 <6.50.0.0)

Commands are suggestions: review each one before running it.

Loading voting…