Windmill: Resource-scoped API tokens can read script contents outside their allowed path via scripts/list_search
CVE-2026-54136GHSA-2ppx-66jv-wpw5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (windmill-api 1.715.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io windmill-api
- Affected
- <= 1.714.1
- Fixed in
- 1.715.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2ppx-66jv-wpw5 lists affected ranges: crates.io windmill-api >=0 <=1.714.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54136: 0.47% estimated exploitation activity in the next 30 days; percentile 40.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A resource-scoped API token can read script contents outside its allowed path scope via GET /api/w/{workspace}/scripts/listsearch. This appears to be a remaining variant of the scoped-token authorization class previously addressed for other endpoints. The route-level scope middleware validates the token domain/action, but does not enforce the resource/path segment of a scope. scripts/listsearch then returns script path and content for scripts in the workspace without applying per-row path filtering against the token scopes. Affected endpoint GET /api/w/{workspace}/scripts/listsearch Affected versions Confirmed in the current public repository code and believed to affect the latest published release at the time of review: <= 1.714.1 Patched version: unknown. Details Windmill supports scoped API tokens with scopes in the format: {domain}:{action}[:{resource}] The parser supports resource-scoped values such as: scripts:read:f/allowed/ and the codebase contains helpers for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2ppx-66jv-wpw5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54136 Advisory: Windmill: Resource-scoped API tokens can read script contents outside their allowed path via scripts/list_search IDs: CVE-2026-54136, GHSA-2ppx-66jv-wpw5 Record: https://patchnext.com/advisories/cve-2026-54136 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: windmill-api 1.715.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io windmill-api: affected <= 1.714.1; fixed in 1.715.0 ## Suggested inspection (read-only) - crates.io windmill-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on windmill-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2ppx-66jv-wpw5 (GitHub-reviewed advisory GHSA-2ppx-66jv-wpw5 lists affected ranges: crates.io windmill-api >=0 <=1.714.1) Commands are suggestions: review each one before running it.
Loading voting…