Skip to content

← Actionable
High, CVSS 7.0amended

OctoPrint has possible file exfiltration via query parameters on upload endpoints

CVE-2026-54134GHSA-j4h9-pm27-4rfw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 2.0.0rc3, 1.11.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI octoprint

    Affected
    <= 1.11.7>= 2.0.0rc1, <= 2.0.0rc2
    Fixed in
    1.11.8, 2.0.0rc3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54134: 0.32% estimated exploitation activity in the next 30 days; percentile 25.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OctoPrint versions up until and including 1.11.7 as well as 2.0.0rc1 and 2.0.0rc2 contain a vulnerability that allows an attacker with the FILEUPLOAD permission to exfiltrate files from the host that OctoPrint has read access to, by moving them into the upload folder where they then can be downloaded from. This vulnerability was already reported as GHSA-m9jh-jf9h-x3h2/CVE-2025-48067 but the fix provided in OctoPrint 1.11.2 turned out to be incomplete. The primary risk lies in the potential exfiltration of secrets stored inside OctoPrint's config, or further system files. By removing important runtime files, this could also be used to impact the availability of the host after an attempted server restart. Given that the attacker requires a user account with file upload permissions, the actual impact of this should however hopefully be minimal in most cases. Patches The vulnerability has been patched in version 1.11.8 and 2.0.0rc3. Details OctoPrint's web application is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j4h9-pm27-4rfw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j4h9-pm27-4rfw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54134

Advisory: OctoPrint has possible file exfiltration via query parameters on upload endpoints
IDs: CVE-2026-54134, GHSA-j4h9-pm27-4rfw
Record: https://patchnext.com/advisories/cve-2026-54134 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: octoprint 2.0.0rc3, 1.11.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI octoprint: affected <= 1.11.7; >= 2.0.0rc1, <= 2.0.0rc2; fixed in 1.11.8, 2.0.0rc3

## Suggested inspection (read-only)
- `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on octoprint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j4h9-pm27-4rfw (OSV record GHSA-j4h9-pm27-4rfw lists affected ranges: PyPI octoprint >=0 =2.0.0rc1 <2.0.0rc3 (fixed))
- Verified: https://github.com/advisories/GHSA-j4h9-pm27-4rfw (GitHub-reviewed advisory GHSA-j4h9-pm27-4rfw lists affected ranges: PyPI octoprint >=0 =2.0.0rc1 <=2.0.0rc2)

Commands are suggestions: review each one before running it.

Loading voting…