EasyAdmin: Stored Cross-Site Scripting (XSS) via uploaded files served inline in FileField and ImageField
CVE-2026-54087GHSA-8559-gwj3-q37r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (easycorp/easyadmin-bundle 5.0.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist easycorp/easyadmin-bundle
- Affected
- >= 5.0.0, < 5.0.13
- Fixed in
- 5.0.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8559-gwj3-q37r lists affected ranges: Packagist easycorp/easyadmin-bundle >=5.0.0 <5.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-54087: 0.40% estimated exploitation activity in the next 30 days; percentile 34.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
EasyAdmin's FileField and ImageField accept browser-executable file types by default (FileField applies no MIME/extension restrictions; ImageField's default Image constraint accepts SVG). When the upload directory is configured inside the public web root — as shown in the documentation — EasyAdmin links to the stored file inline (no download attribute or Content-Disposition: attachment). An attacker with access to a form using these fields can upload an .html (FileField) or .svg (ImageField) file containing JavaScript. When another user opens it from the backend, it is served from the same origin and the script executes in the context of their authenticated admin session, enabling session/CSRF-token theft or privilege escalation. Exploitation requires the developer to store uploads in the public directory and a privilege gap between the uploading user and the viewing administrator. This is stored XSS only — it does not allow remote code execution, because uploaded filenames are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8559-gwj3-q37r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54087 Advisory: EasyAdmin: Stored Cross-Site Scripting (XSS) via uploaded files served inline in FileField and ImageField IDs: CVE-2026-54087, GHSA-8559-gwj3-q37r Record: https://patchnext.com/advisories/cve-2026-54087 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: easycorp/easyadmin-bundle 5.0.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist easycorp/easyadmin-bundle: affected >= 5.0.0, < 5.0.13; fixed in 5.0.13 ## Suggested inspection (read-only) - Packagist easycorp/easyadmin-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on easycorp/easyadmin-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8559-gwj3-q37r (GitHub-reviewed advisory GHSA-8559-gwj3-q37r lists affected ranges: Packagist easycorp/easyadmin-bundle >=5.0.0 <5.0.13) Commands are suggestions: review each one before running it.
Loading voting…