veraPDF Parser DoS via PostScript CMap Streams
CVE-2026-54080GHSA-jrmc-qg6p-94fp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.verapdf:parser 1.31.23, 1.30.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.verapdf:parser
- Affected
- <= 1.30.1>= 1.31.1, <= 1.31.22
- Fixed in
- 1.31.23, 1.30.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jrmc-qg6p-94fp lists affected ranges: Maven org.verapdf:parser >=0 =1.31.1 <1.31.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jrmc-qg6p-94fp lists affected ranges: Maven org.verapdf:parser >=0 =1.31.1 <=1.31.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54080: 0.52% estimated exploitation activity in the next 30 days; percentile 44.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Description A PostScript-interpreter-driven Denial of Service (CWE-1325) vulnerability in veraPDF allows a remote attacker to exhaust validator memory or CPU by submitting a PDF whose Type 0 font /Encoding (or any /ToUnicode) is a CMap stream containing attacker-supplied PostScript. veraPDF reuses its CMap parser as a general PostScript interpreter and exposes the unguarded array N allocation operator and the for control operator with no zero-increment guard. This affects all current versions of veraPDF-parser. Details The vulnerability resides in veraPDF-parser. CMap streams referenced as a Type 0 font's /Encoding (or any font's /ToUnicode) are parsed by CMapParser (veraPDF-parser/src/main/java/org/verapdf/pd/font/cmap/CMapParser.java), which extends PSParser. Tokens that are not the small CMap-specific keyword set (begincodespacerange, bfchar, cidchar, ...) fall through to PSObject.execute (veraPDF-parser/src/main/java/org/verapdf/parser/postscript/PSObject.java), which…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jrmc-qg6p-94fp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jrmc-qg6p-94fp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54080 Advisory: veraPDF Parser DoS via PostScript CMap Streams IDs: CVE-2026-54080, GHSA-jrmc-qg6p-94fp Record: https://patchnext.com/advisories/cve-2026-54080 (revision 3, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.verapdf:parser 1.31.23, 1.30.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.verapdf:parser: affected <= 1.30.1; >= 1.31.1, <= 1.31.22; fixed in 1.31.23, 1.30.2 ## Suggested inspection (read-only) - Maven org.verapdf:parser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.verapdf:parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jrmc-qg6p-94fp (OSV record GHSA-jrmc-qg6p-94fp lists affected ranges: Maven org.verapdf:parser >=0 =1.31.1 <1.31.23 (fixed)) - Verified: https://github.com/advisories/GHSA-jrmc-qg6p-94fp (GitHub-reviewed advisory GHSA-jrmc-qg6p-94fp lists affected ranges: Maven org.verapdf:parser >=0 =1.31.1 <=1.31.22) Commands are suggestions: review each one before running it.
Loading voting…