ArcadeDB: IMPORT DATABASE allows SSRF and arbitrary local file read by authenticated users
CVE-2026-54077GHSA-8w86-m9h8-hvqg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.arcadedb:arcadedb-engine 26.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.arcadedb:arcadedb-engine
- Affected
- < 26.6.1
- Fixed in
- 26.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8w86-m9h8-hvqg lists affected ranges: Maven com.arcadedb:arcadedb-engine >=0 <26.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
- EPSS
- CVE-2026-54077: 0.45% estimated exploitation activity in the next 30 days; percentile 38.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The SQL IMPORT DATABASE statement did not require administrative privileges and passed its source URL to the importer without validation. Any authenticated user with SQL command access (not only root/administrators) could therefore: - Server-Side Request Forgery (CWE-918): cause the server to issue HTTP(S) requests to arbitrary destinations, including cloud metadata endpoints (e.g. 169.254.169.254) and internal-only services, and ingest the responses as queryable records. - Arbitrary local file read (CWE-22): read local files reachable by the server process (e.g. /etc/passwd, credential files) by importing file:// paths, exposing their contents as records. The server administration endpoint (/api/v1/server) was already restricted to the root user and was not affected; the exposure was through the database SQL command/query endpoints (/api/v1/command, /api/v1/query). A related lower-severity hardening gap (CWE-776): the XML importer did not disable DTD processing, leaving…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8w86-m9h8-hvqg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54077 Advisory: ArcadeDB: IMPORT DATABASE allows SSRF and arbitrary local file read by authenticated users IDs: CVE-2026-54077, GHSA-8w86-m9h8-hvqg Record: https://patchnext.com/advisories/cve-2026-54077 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.arcadedb:arcadedb-engine 26.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.arcadedb:arcadedb-engine: affected < 26.6.1; fixed in 26.6.1 ## Suggested inspection (read-only) - Maven com.arcadedb:arcadedb-engine: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.arcadedb:arcadedb-engine. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8w86-m9h8-hvqg (GitHub-reviewed advisory GHSA-8w86-m9h8-hvqg lists affected ranges: Maven com.arcadedb:arcadedb-engine >=0 <26.6.1) Commands are suggestions: review each one before running it.
Loading voting…