Skip to content

← Actionable
Critical, CVSS 9.3

Authorizer: Unvalidated redirect_uri in /authorize leaks OAuth2 tokens to attacker-controlled URL

CVE-2026-54072GHSA-h29v-hj44-q8cv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/authorizerdev/authorizer 0.0.0-20260409051328-bd3f5baf6d3d), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-54072: 0.46% estimated exploitation activity in the next 30 days; percentile 40.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /authorize endpoint accepts any redirecturi without validating it against AllowedOrigins. When responsetype=token or responsetype=idtoken, the server appends accesstoken, idtoken, and refreshtoken as query parameters and issues a 302 redirect to the attacker-supplied URL. An unauthenticated attacker can obtain the required clientid from the public /graphql?query={meta{clientid}} endpoint. Partial fix was applied in v2.0.1 to other handlers (oauthlogin, verifyemail, magiclinklogin, forgotpassword, invitemembers, oauthcallback) but /authorize was not included. Vulnerable Code internal/httphandlers/authorize.go: Compare with the fixed oauthlogin.go in v2.0.1 which calls validators.IsValidOrigin(redirectURI, h.Config.AllowedOrigins). Steps to Reproduce Impact An attacker who tricks a logged-in user into clicking a crafted link can steal the victim's accesstoken, idtoken, and refreshtoken. The attacker can then impersonate the victim for the full token lifetime. No user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h29v-hj44-q8cv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54072

Advisory: Authorizer: Unvalidated redirect_uri in /authorize leaks OAuth2 tokens to attacker-controlled URL
IDs: CVE-2026-54072, GHSA-h29v-hj44-q8cv
Record: https://patchnext.com/advisories/cve-2026-54072 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/authorizerdev/authorizer 0.0.0-20260409051328-bd3f5baf6d3d. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/authorizerdev/authorizer: affected < 0.0.0-20260409051328-bd3f5baf6d3d; fixed in 0.0.0-20260409051328-bd3f5baf6d3d

## Suggested inspection (read-only)
- Go github.com/authorizerdev/authorizer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/authorizerdev/authorizer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h29v-hj44-q8cv (GitHub-reviewed advisory GHSA-h29v-hj44-q8cv lists affected ranges: Go github.com/authorizerdev/authorizer >=0 <0.0.0-20260409051328-bd3f5baf6d3d)

Commands are suggestions: review each one before running it.

Loading voting…