Skip to content

← Actionable
Critical, CVSS 9.9amended

n8n-MCP: Cross-tenant access to workflow version backups in multi-tenant HTTP deployments

CVE-2026-54052GHSA-j6r7-6fhx-77wx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n-mcp 2.56.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n-mcp

    Affected
    <= 2.56.0
    Fixed in
    2.56.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2026-54052: 0.39% estimated exploitation activity in the next 30 days; percentile 33.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In multi-tenant HTTP deployments — where a single n8n-mcp server serves several tenants — the locally stored workflow version history (the automatic backups taken before workflow updates) was not isolated per tenant. An authenticated tenant could read workflow version snapshots belonging to other tenants, and could delete or destroy other tenants' stored backups. A stored snapshot includes full node definitions, so the exposed data can contain credential references and authorization headers configured on nodes. This is therefore a confidentiality issue in addition to an integrity/availability one. Affected configurations - HTTP mode with multi-tenancy enabled (ENABLEMULTITENANT=true), where multiple tenants are served by a single shared instance and database. Not affected: - stdio / single-user deployments (e.g. Claude Desktop). - Single-tenant HTTP deployments (one tenant per instance and database). Affected versions <= 2.56.0 Patched version 2.56.1. The stored version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j6r7-6fhx-77wx

  2. Revision 2 · amended ·

    Amended from osv record GHSA-j6r7-6fhx-77wx

  3. Revision 1 · created ·

    Published from ghsa record GHSA-j6r7-6fhx-77wx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54052

Advisory: n8n-MCP: Cross-tenant access to workflow version backups in multi-tenant HTTP deployments
IDs: CVE-2026-54052, GHSA-j6r7-6fhx-77wx
Record: https://patchnext.com/advisories/cve-2026-54052 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n-mcp 2.56.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n-mcp: affected <= 2.56.0; fixed in 2.56.1

## Suggested inspection (read-only)
- `npm ls n8n-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j6r7-6fhx-77wx (GitHub-reviewed advisory GHSA-j6r7-6fhx-77wx lists affected ranges: npm n8n-mcp >=0 <=2.56.0)
- Verified: https://osv.dev/vulnerability/GHSA-j6r7-6fhx-77wx (OSV record GHSA-j6r7-6fhx-77wx lists affected ranges: npm n8n-mcp >=0 <2.56.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…