Skip to content

← Actionable
Critical, CVSS 9.9amended

Network-AI: Improper Neutralization of Special Elements used in an OS Command

CVE-2026-54051GHSA-qw6v-5fcf-5666

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-54051: 0.47% estimated exploitation activity in the next 30 days; percentile 40.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The agent sandbox gates shell commands behind an allowlist (SandboxPolicy.isCommandAllowed), which THREATMODEL.md calls the main control against a compromised agent (Adversary 3.2). The allowlist glob-matches the whole command string, but ShellExecutor runs that string through /bin/sh -c. So any wildcard allow such as git , npm or node also matches git status; <anything, and a scoped command becomes arbitrary execution. Root cause Matching and execution disagree on what a command is. Lines pinned to 40e42d7 (lib/agent-runtime.ts is identical to the v5.8.5 tag). 1. isCommandAllowed matches the full string, with no tokenizing and no metacharacter check: https://github.com/Jovancoding/Network-AI/blob/40e42d7a0a966b948953b3c524cf15355d20ef5e/lib/agent-runtime.ts#L248-L260 2. globMatch compiles to . and anchors it, so git becomes ^git .$ and matches git status; id:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qw6v-5fcf-5666

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qw6v-5fcf-5666

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qw6v-5fcf-5666

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54051

Advisory: Network-AI: Improper Neutralization of Special Elements used in an OS Command
IDs: CVE-2026-54051, GHSA-qw6v-5fcf-5666
Record: https://patchnext.com/advisories/cve-2026-54051 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: network-ai 5.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm network-ai: affected < 5.9.1; fixed in 5.9.1

## Suggested inspection (read-only)
- `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on network-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qw6v-5fcf-5666 (GitHub-reviewed advisory GHSA-qw6v-5fcf-5666 lists affected ranges: npm network-ai >=0 <5.9.1)
- Verified: https://osv.dev/vulnerability/GHSA-qw6v-5fcf-5666 (OSV record GHSA-qw6v-5fcf-5666 lists affected ranges: npm network-ai >=0 <5.9.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…