Open WebUI: Path traversal / SSRF in terminal server proxy via encoded path traversal
CVE-2026-54017GHSA-r2wg-2mcr-66rv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- <= 0.9.5
- Fixed in
- 0.9.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r2wg-2mcr-66rv lists affected ranges: PyPI open-webui >=0 <0.9.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r2wg-2mcr-66rv lists affected ranges: PyPI open-webui >=0 <=0.9.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-54017: 0.52% estimated exploitation activity in the next 30 days; percentile 44.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The terminal-server reverse proxy in backend/openwebui/routers/terminals.py does not fully confine the user-controlled path segment before forwarding it to an admin-configured terminal server. An authenticated user who has been granted access to a terminal server can craft path values containing encoded ../ traversal sequences that escape the intended path (or policy) scope on that server, reaching unintended endpoints and files on the terminal-server host. Where the terminal server fans requests out to internal services, this also gives SSRF-style reach into those services. This is a separate code path from the /api/v1/retrieval/process/web SSRF (GHSA-c6xv-rcvw-v685), with its own input. Two distinct vectors are consolidated here: 1. Raw path forwarding / single-encoded traversal (original report). 2. A bypass of the subsequently-added sanitizeproxypath mitigation using double-encoded dots (%252e%252e). The attacker-controlled input is the request path, supplied by the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r2wg-2mcr-66rv
- Revision 1 · created ·
Published from osv record GHSA-r2wg-2mcr-66rv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54017 Advisory: Open WebUI: Path traversal / SSRF in terminal server proxy via encoded path traversal IDs: CVE-2026-54017, GHSA-r2wg-2mcr-66rv Record: https://patchnext.com/advisories/cve-2026-54017 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected <= 0.9.5; fixed in 0.9.6 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r2wg-2mcr-66rv (OSV record GHSA-r2wg-2mcr-66rv lists affected ranges: PyPI open-webui >=0 <0.9.6 (fixed)) - Verified: https://github.com/advisories/GHSA-r2wg-2mcr-66rv (GitHub-reviewed advisory GHSA-r2wg-2mcr-66rv lists affected ranges: PyPI open-webui >=0 <=0.9.5) Commands are suggestions: review each one before running it.
Loading voting…