Skip to content

← Actionable
Medium, CVSS 6.4amended

Open WebUI Prompt history IDOR: unbound history_id allows cross-prompt read and deletion

CVE-2026-54015GHSA-4r4w-2wgp-w7cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-54015: 0.27% estimated exploitation activity in the next 30 days; percentile 19.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Open WebUI's prompt version-history endpoints authorize the promptid in the URL but then act on caller-supplied history IDs without verifying that the history row belongs to that prompt (historyentry.promptid == prompt.id). Three operations are affected: - GET /api/v1/prompts/id/{promptid}/history/diff — returns another prompt's history snapshots (read). - POST /api/v1/prompts/id/{promptid}/update/version — restores another prompt's snapshot into the caller's prompt, exposing its content (read). - DELETE /api/v1/prompts/id/{promptid}/history/{historyid} — deletes another prompt's history entry (delete). An authenticated user with access to any prompt they control, plus a victim prompthistory.id, can read or delete another user's private prompt history. The single-entry read endpoint (GET .../history/{historyid}) already enforces the binding; these three did not. Impact Security boundary crossed: prompt confidentiality and integrity. Prompt history snapshots can contain…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4r4w-2wgp-w7cj

  2. Revision 1 · created ·

    Published from osv record GHSA-4r4w-2wgp-w7cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54015

Advisory: Open WebUI Prompt history IDOR: unbound history_id allows cross-prompt read and deletion
IDs: CVE-2026-54015, GHSA-4r4w-2wgp-w7cj
Record: https://patchnext.com/advisories/cve-2026-54015 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.9.5; fixed in 0.9.6

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4r4w-2wgp-w7cj (OSV record GHSA-4r4w-2wgp-w7cj lists affected ranges: PyPI open-webui >=0 <0.9.6 (fixed))
- Verified: https://github.com/advisories/GHSA-4r4w-2wgp-w7cj (GitHub-reviewed advisory GHSA-4r4w-2wgp-w7cj lists affected ranges: PyPI open-webui >=0 <=0.9.5)

Commands are suggestions: review each one before running it.

Loading voting…