Skip to content

← Actionable
Medium, CVSS 4.3amended

Open WebUI: Sibling-Prefix Path Traversal via /cache/{path}

CVE-2026-54014GHSA-j2c8-v969-8r5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-54014: 0.36% estimated exploitation activity in the next 30 days; percentile 29.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability exists in open-webui's cache file serving endpoint that allows any authenticated user to read files from sibling directories outside the intended cache directory, by exploiting an incomplete startswith containment check that lacks a trailing path separator. The root cause is that servecachefile() in openwebui/main.py validates the resolved path with filepath.startswith(os.path.abspath(CACHEDIR)) — without appending os.sep. This allows any path resolving to a sibling directory whose name begins with cache (e.g. cachesibling, cachebackup, cachedmodels) to pass validation. Deep traversal and absolute paths are correctly blocked. The bypass is narrow but confirmed — limited to sibling-prefix directories. Exploitation constraints | Constraint | Detail | |---|---| | Auth required | getverifieduser — any user with role user or admin | | Scope | Only sibling directories starting with cache (e.g. cachebackup, cachedmodels) | | Deep traversal | Blocked —…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j2c8-v969-8r5c

  2. Revision 1 · created ·

    Published from osv record GHSA-j2c8-v969-8r5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54014

Advisory: Open WebUI: Sibling-Prefix Path Traversal via /cache/{path}
IDs: CVE-2026-54014, GHSA-j2c8-v969-8r5c
Record: https://patchnext.com/advisories/cve-2026-54014 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.9.5; fixed in 0.9.6

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j2c8-v969-8r5c (OSV record GHSA-j2c8-v969-8r5c lists affected ranges: PyPI open-webui >=0 <0.9.6 (fixed))
- Verified: https://github.com/advisories/GHSA-j2c8-v969-8r5c (GitHub-reviewed advisory GHSA-j2c8-v969-8r5c lists affected ranges: PyPI open-webui >=0 <=0.9.5)

Commands are suggestions: review each one before running it.

Loading voting…