Skip to content

← Actionable
High, CVSS 7.6amended

Open WebUI: Stored XSS to Account Takeover via Model Profile Images

CVE-2026-54013GHSA-v2qm-5wxj-qhj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-54013: 0.30% estimated exploitation activity in the next 30 days; percentile 22.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Stored XSS to Account Takeover via Model Profile Images in Open WebUI Affected: Open WebUI <= 0.9.5 Bypass of: GHSA-3wgj-c2hg-vm6q, GHSA-3856-3vxq-m6fc --- TL;DR Open WebUI patched SVG XSS in user profile images and webhook profile images but forgot to apply the same fix to model profile images. The ModelMeta class has no validateprofileimageurl field validator, and the model image serving endpoint has no MIME allowlist or nosniff header. Any authenticated user with workspace.models permission (enabled by default) can store a data:image/svg+xml;base64,... payload in a model's profile image and achieve full account takeover of anyone who navigates to the image URL. --- Past of the issue In early 2025, two security advisories landed for Open WebUI: - GHSA-3wgj-c2hg-vm6q SVG XSS via user profile images - GHSA-3856-3vxq-m6fc SVG XSS via webhook profile images The patches were clean. A validateprofileimageurl function was introduced in backend/openwebui/utils/validate.py a compiled regex…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v2qm-5wxj-qhj7

  2. Revision 1 · created ·

    Published from osv record GHSA-v2qm-5wxj-qhj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54013

Advisory: Open WebUI: Stored XSS to Account Takeover via Model Profile Images
IDs: CVE-2026-54013, GHSA-v2qm-5wxj-qhj7
Record: https://patchnext.com/advisories/cve-2026-54013 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.9.5; fixed in 0.9.6

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v2qm-5wxj-qhj7 (OSV record GHSA-v2qm-5wxj-qhj7 lists affected ranges: PyPI open-webui >=0 <0.9.6 (fixed))
- Verified: https://github.com/advisories/GHSA-v2qm-5wxj-qhj7 (GitHub-reviewed advisory GHSA-v2qm-5wxj-qhj7 lists affected ranges: PyPI open-webui >=0 <=0.9.5)

Commands are suggestions: review each one before running it.

Loading voting…