Kirby: pages.access permission is not checked in the site/find REST API route
CVE-2026-54005GHSA-r3w8-2c5r-h9j9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.4, 4.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 4.9.3>= 5.0.0-alpha.1, <= 5.4.3
- Fixed in
- 4.9.4, 5.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3w8-2c5r-h9j9 lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54005: 0.43% estimated exploitation activity in the next 30 days; percentile 37.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects all Kirby sites where users of a particular role have no permission to access pages (pages.access permission is disabled). This can be due to configuration in the user blueprint(s), options in the model blueprint(s), or a combination of both settings. It was possible to retrieve page information (including full content and metadata) for arbitrary pages via the /api/site/find route without being authorized to access the respective pages. This vulnerability is of high severity for affected sites. Your Kirby sites are not affected if you intend all users of your site to be able to access all pages of the site. The vulnerability can only be exploited by authenticated users that know or guess the IDs or UUIDs of pages. Write actions as well as access to draft pages are not affected by this vulnerability. ---- Introduction Missing authorization allows authenticated users to perform actions they are not intended to have access to. The effects of missing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r3w8-2c5r-h9j9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54005 Advisory: Kirby: `pages.access` permission is not checked in the `site/find` REST API route IDs: CVE-2026-54005, GHSA-r3w8-2c5r-h9j9 Record: https://patchnext.com/advisories/cve-2026-54005 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.4, 4.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 4.9.3; >= 5.0.0-alpha.1, <= 5.4.3; fixed in 4.9.4, 5.4.4 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r3w8-2c5r-h9j9 (GitHub-reviewed advisory GHSA-r3w8-2c5r-h9j9 lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3) Commands are suggestions: review each one before running it.
Loading voting…