Kirby: External Initialization of the Panel on reverse proxy setups with the Forwarded header
CVE-2026-54003GHSA-whxw-24jc-cwmv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.4, 4.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 4.9.3>= 5.0.0-alpha.1, <= 5.4.3
- Fixed in
- 4.9.4, 5.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-whxw-24jc-cwmv lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54003: 0.74% estimated exploitation activity in the next 30 days; percentile 54.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects Kirby sites that have no configured user accounts and are running on publicly accessible servers behind a reverse proxy that sets the Forwarded: for=..., X-Client-IP, or X-Real-IP request header. It was possible to install the Panel (= create the first admin user) in these setups even from remote IP addresses. This vulnerability is of critical severity for affected sites. Your site is not affected if any of the following apply: - An admin account has already been configured - The Panel and API are disabled - The site is not running behind a reverse proxy - The reverse proxy sets the X-Forwarded-For or Client-IP header instead of the affected ones. ---- Introduction External Initialization is a type of vulnerability that allows attackers to initialize a system or configuration value without authentication. This can give untrusted actors access to the system or let them control its behavior. Affected components The Kirby Panel and REST API are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-whxw-24jc-cwmv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54003 Advisory: Kirby: External Initialization of the Panel on reverse proxy setups with the `Forwarded` header IDs: CVE-2026-54003, GHSA-whxw-24jc-cwmv Record: https://patchnext.com/advisories/cve-2026-54003 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.4, 4.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 4.9.3; >= 5.0.0-alpha.1, <= 5.4.3; fixed in 4.9.4, 5.4.4 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-whxw-24jc-cwmv (GitHub-reviewed advisory GHSA-whxw-24jc-cwmv lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3) Commands are suggestions: review each one before running it.
Loading voting…