Kirby: Cross-site scripting (XSS) from incomplete HTML/XML sanitization in Dom::sanitize()
CVE-2026-54002GHSA-wr9h-4r83-f4v6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.4, 4.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 4.9.3>= 5.0.0-alpha.1, <= 5.4.3
- Fixed in
- 4.9.4, 5.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wr9h-4r83-f4v6 lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54002: 0.55% estimated exploitation activity in the next 30 days; percentile 45.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects Kirby sites and plugins that use the writer or list fields or that use $dom-sanitize(), Sane::sanitize(), Sane\Html::sanitize(), Sane\Svg::sanitize(), Sane\Xml::sanitize(), Sane::sanitizeFile() or $file-sanitizeContents() with untrusted input. It was possible to inject malicious markup as children of an unknown HTML/XML tag, which would then be passed through Dom::sanitize() without being correctly sanitized according to the provided sanitization rules, causing a cross-site scripting (XSS) risk. This vulnerability is of high severity for affected sites. The default file upload protection is not affected, so sites that only validate uploaded files are not exposed to this vulnerability. The vulnerability can only be exploited by authenticated users. ---- Introduction Cross-site scripting (XSS) is a type of vulnerability that allows executing any kind of JavaScript code inside the site frontend or Panel session of the same or other users. In the Panel, a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wr9h-4r83-f4v6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54002 Advisory: Kirby: Cross-site scripting (XSS) from incomplete HTML/XML sanitization in `Dom::sanitize()` IDs: CVE-2026-54002, GHSA-wr9h-4r83-f4v6 Record: https://patchnext.com/advisories/cve-2026-54002 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.4, 4.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 4.9.3; >= 5.0.0-alpha.1, <= 5.4.3; fixed in 4.9.4, 5.4.4 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wr9h-4r83-f4v6 (GitHub-reviewed advisory GHSA-wr9h-4r83-f4v6 lists affected ranges: Packagist getkirby/cms >=0 =5.0.0-alpha.1 <=5.4.3) Commands are suggestions: review each one before running it.
Loading voting…