Skip to content

← Actionable
High, CVSS 8.8amended

MLflow FileStore trace IDs allow path traversal and arbitrary file writes

CVE-2026-53995GHSA-wqmh-qccw-pqwf

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mlflow

    Affected
    < 3.17.2
    Fixed in
    3.17.2
  • Bitnami mlflow

    Affected
    <= 3.17.2
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-53995: 0.63% estimated exploitation activity in the next 30 days; percentile 50.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

MLflow 3.17.1 and earlier contains a path traversal vulnerability in the FileStore tracking backend that allows unauthenticated attackers to control filesystem paths by submitting a crafted trace ID containing traversal sequences to the POST /api/3.0/mlflow/traces endpoint. Attackers can exploit FileStore.start_trace() to write trace_info.yaml, request_metadata, and tag files with attacker-controlled metadata outside the intended experiment trace directory, subject to the server process's filesystem permissions. FileStore is the default tracking backend before MLflow 3.7.0 and opt-in thereafter (the default changed to a SQLite database), so deployments in the earlier part of the affected range are vulnerable without special configuration while later ones are affected only when FileStore is explicitly selected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-wqmh-qccw-pqwf

  2. Revision 3 · amended ·

    Amended from osv record BIT-mlflow-2026-53995

  3. Revision 2 · amended ·

    Amended from osv record GHSA-wqmh-qccw-pqwf

  4. Revision 1 · created ·

    Published from ghsa record GHSA-wqmh-qccw-pqwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53995

Advisory: MLflow FileStore trace IDs allow path traversal and arbitrary file writes
IDs: CVE-2026-53995, GHSA-wqmh-qccw-pqwf
Record: https://patchnext.com/advisories/cve-2026-53995 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: mlflow 3.17.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mlflow: affected < 3.17.2; fixed in 3.17.2
- Bitnami mlflow: affected <= 3.17.2

## Suggested inspection (read-only)
- `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active.
- Bitnami mlflow: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mlflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wqmh-qccw-pqwf (GitHub-reviewed advisory GHSA-wqmh-qccw-pqwf lists affected ranges: PyPI mlflow >=0 <=3.17.1)
- Verified: https://osv.dev/vulnerability/GHSA-wqmh-qccw-pqwf (OSV record GHSA-wqmh-qccw-pqwf lists affected ranges: PyPI mlflow >=0 <3.17.2 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-mlflow-2026-53995 (OSV record BIT-mlflow-2026-53995 lists affected ranges: Bitnami mlflow >=0 <=3.17.2)

Commands are suggestions: review each one before running it.

Loading voting…