Skip to content

← Actionable
High, CVSS 7.1amended

XWiki Platform Live Data Live Table Connector has privilege escalation from edit to script right through Live Data editing

CVE-2026-53966GHSA-45ph-gxxr-gwgw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-livedata-livetable 18.1.0-rc-1, 17.10.4, 17.4.10, 16.10.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-45ph-gxxr-gwgw lists affected ranges: Maven org.xwiki.platform:xwiki-platform-livedata-livetable >=13.4-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 =18.0.0-rc-1 <18.1.0-rc-1 (fixed)

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-45ph-gxxr-gwgw lists affected ranges: Maven org.xwiki.platform:xwiki-platform-livedata-livetable >=13.4-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 =18.0.0-rc-1 <18.1.0-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-53966: 0.77% estimated exploitation activity in the next 30 days; percentile 55.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any user who can edit a page in XWiki can use Live Data's edit REST API in XWiki to change the rights on that page. This allows the user to obtain script right on the page. Script right allows the user to execute potentially dangerous Velocity scripts and send unfiltered HTML and JavaScript to the client. If there are other security checks, e.g., in extensions, implemented as listeners to UserUpdatingDocumentEvent and similar User… events, these checks can be circumvented, too. Patches This vulnerability has been patched by properly calling all checks in Live Data in XWiki 16.10.17, 17.4.10, 17.10.4 and 18.1.0. Workarounds We're not aware of any workarounds apart from upgrading.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-45ph-gxxr-gwgw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-45ph-gxxr-gwgw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53966

Advisory: XWiki Platform Live Data Live Table Connector has privilege escalation from edit to script right through Live Data editing
IDs: CVE-2026-53966, GHSA-45ph-gxxr-gwgw
Record: https://patchnext.com/advisories/cve-2026-53966 (revision 3, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-livedata-livetable 18.1.0-rc-1, 17.10.4, 17.4.10, 16.10.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-livedata-livetable: affected >= 13.4-rc-1, < 16.10.17; >= 17.0.0-rc-1, < 17.4.10; >= 17.5.0-rc-1, < 17.10.4; >= 18.0.0-rc-1, < 18.1.0-rc-1; fixed in 16.10.17, 17.10.4, 17.4.10, 18.1.0-rc-1

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-livedata-livetable: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-livedata-livetable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-45ph-gxxr-gwgw (OSV record GHSA-45ph-gxxr-gwgw lists affected ranges: Maven org.xwiki.platform:xwiki-platform-livedata-livetable >=13.4-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 =18.0.0-rc-1 <18.1.0-rc-1 (fixed))
- Verified: https://github.com/advisories/GHSA-45ph-gxxr-gwgw (GitHub-reviewed advisory GHSA-45ph-gxxr-gwgw lists affected ranges: Maven org.xwiki.platform:xwiki-platform-livedata-livetable >=13.4-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 =18.0.0-rc-1 <18.1.0-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…