Skip to content

← Actionable
High, CVSS 7.2

Document Merge Service vulnerable to RCE via SSTI (xlsx tempaltes)

CVE-2026-53964GHSA-w47q-945m-q9pc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (document-merge-service 9.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-53964: 0.49% estimated exploitation activity in the next 30 days; percentile 42.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote code execution (RCE) via server-side template injection (SSTI) allows for user supplied code to be executed in the server's context where it is executed as the document-merge-server user with the UID 901 thus giving an attacker considerable control over the container. The vulnerability is limited to XLSX templates, were the xltpl library uses a npn-sandboxed Jinja environment for the processing of the template. Patches It has been patched in v9.1.0 Workarounds Disable the upload/usage of XLSX templates. References Are there any links users can visit to find out more? https://book.hacktricks.xyz/pentesting-web/ssti-server-side-template-injection/jinja2-ssti

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w47q-945m-q9pc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53964

Advisory: Document Merge Service vulnerable to RCE via SSTI (xlsx tempaltes)
IDs: CVE-2026-53964, GHSA-w47q-945m-q9pc
Record: https://patchnext.com/advisories/cve-2026-53964 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: document-merge-service 9.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI document-merge-service: affected < 9.1.0; fixed in 9.1.0

## Suggested inspection (read-only)
- `python -m pip show document-merge-service`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on document-merge-service.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w47q-945m-q9pc (GitHub-reviewed advisory GHSA-w47q-945m-q9pc lists affected ranges: PyPI document-merge-service >=0 <9.1.0)

Commands are suggestions: review each one before running it.

Loading voting…