Contentful MCP Server: export_space/import_space tools pass LLM-controlled host/proxy args to CMA client, redirecting server PAT to attacker-controlled endpoint
CVE-2026-53957GHSA-2xhg-73j7-rrgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@contentful/mcp-tools 0.4.5; @contentful/mcp-server 1.7.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.4.5
- Fixed in
- 0.4.5
- Affected
- < 1.7.19
- Fixed in
- 1.7.19
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2xhg-73j7-rrgx lists affected ranges: npm @contentful/mcp-server >=0 =0 <0.4.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2xhg-73j7-rrgx lists affected ranges: npm @contentful/mcp-server >=0 =0 <0.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-53957: 0.41% estimated exploitation activity in the next 30 days; percentile 35.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary exportspace and importspace tools in @contentful/mcp-tools accept LLM-controlled host and proxy parameters that are spread directly into the options object passed to contentful-export / contentful-import. These libraries pass the merged options — including the attacker-controlled host — to the Contentful Management API (CMA) SDK, which builds baseURL from host and attaches the server's CMA Personal Access Token as Authorization: Bearer <PAT on every outgoing request. An attacker who can invoke MCP tools, or inject instructions into Contentful content the LLM reads, can redirect all CMA requests — and the PAT — to an attacker-controlled endpoint. --- Details Root cause — exportSpace.ts lines 126–141 (identical pattern in importSpace.ts lines 103–119): createClientConfig (defined in utils/tools.ts) extracts only accessToken and ignores config.host. The CONTENTFULHOST environment variable is never applied to exportOptions. The downstream chain once contentful-export receives the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2xhg-73j7-rrgx
- Revision 1 · created ·
Published from osv record GHSA-2xhg-73j7-rrgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53957 Advisory: Contentful MCP Server: export_space/import_space tools pass LLM-controlled `host`/`proxy` args to CMA client, redirecting server PAT to attacker-controlled endpoint IDs: CVE-2026-53957, GHSA-2xhg-73j7-rrgx Record: https://patchnext.com/advisories/cve-2026-53957 (revision 2, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @contentful/mcp-tools 0.4.5; @contentful/mcp-server 1.7.19. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @contentful/mcp-tools: affected < 0.4.5; fixed in 0.4.5 - npm @contentful/mcp-server: affected < 1.7.19; fixed in 1.7.19 ## Suggested inspection (read-only) - `npm ls @contentful/mcp-tools --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @contentful/mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @contentful/mcp-tools, @contentful/mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2xhg-73j7-rrgx (OSV record GHSA-2xhg-73j7-rrgx lists affected ranges: npm @contentful/mcp-server >=0 =0 <0.4.5 (fixed)) - Verified: https://github.com/advisories/GHSA-2xhg-73j7-rrgx (GitHub-reviewed advisory GHSA-2xhg-73j7-rrgx lists affected ranges: npm @contentful/mcp-server >=0 =0 <0.4.5) Commands are suggestions: review each one before running it.
Loading voting…