Rattler vulnerable to package cache path traversal via conda package build string
CVE-2026-53956GHSA-h672-p7h7-97v9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (py-rattler 0.24.0; rattler_cache 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI py-rattler
- Affected
- <= 0.23.2
- Fixed in
- 0.24.0
crates.io rattler_cache
- Affected
- <= 0.8.2
- Fixed in
- 0.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h672-p7h7-97v9 lists affected ranges: crates.io rattler_cache >=0 =0 <0.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h672-p7h7-97v9 lists affected ranges: crates.io rattler_cache >=0 =0 <=0.23.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-53956: 0.33% estimated exploitation activity in the next 30 days; percentile 26.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
rattlercache and py-rattler were vulnerable to package-cache path traversal when handling package metadata from conda channels. During cache materialization, the rattercache code used the package record build string as part of a cache key that was joined into a filesystem path. A malicious or untrusted channel could publish repodata with path separators or traversal components in that field, causing package contents to be written outside the configured package cache directory. The issue requires use of a malicious or otherwise untrusted conda channel. Curated channels that validate package metadata are not expected to allow malformed build strings of this form. Users should upgrade to a patched version and avoid untrusted conda channels.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h672-p7h7-97v9
- Revision 1 · created ·
Published from osv record GHSA-h672-p7h7-97v9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53956 Advisory: Rattler vulnerable to package cache path traversal via conda package build string IDs: CVE-2026-53956, GHSA-h672-p7h7-97v9 Record: https://patchnext.com/advisories/cve-2026-53956 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: py-rattler 0.24.0; rattler_cache 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI py-rattler: affected <= 0.23.2; fixed in 0.24.0 - crates.io rattler_cache: affected <= 0.8.2; fixed in 0.9.0 ## Suggested inspection (read-only) - `python -m pip show py-rattler`: prints the installed version. Run with the environment that serves production active. - crates.io rattler_cache: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on py-rattler, rattler_cache. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h672-p7h7-97v9 (OSV record GHSA-h672-p7h7-97v9 lists affected ranges: crates.io rattler_cache >=0 =0 <0.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h672-p7h7-97v9 (GitHub-reviewed advisory GHSA-h672-p7h7-97v9 lists affected ranges: crates.io rattler_cache >=0 =0 <=0.23.2) Commands are suggestions: review each one before running it.
Loading voting…