Ghost: Cache-poisoning XSS in Ghost frontend via x-ghost-preview header
CVE-2026-53943GHSA-62q6-4hv4-vjrw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.37.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- >= 4.0.0, <= 6.36.0
- Fixed in
- 6.37.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-62q6-4hv4-vjrw lists affected ranges: npm ghost >=4.0.0 <=6.36.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-62q6-4hv4-vjrw lists affected ranges: npm ghost >=4.0.0 <6.37.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-53943: 0.45% estimated exploitation activity in the next 30 days; percentile 38.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When Ghost is behind a shared caching layer that results in cached content being shared between different visitors (e.g., Fastly, Cloudflare, nginx proxycache, and others), an unauthenticated user could send an x-ghost-preview header that altered the rendered frontend response. In affected cache configurations, that response could be stored and served to subsequent visitors requesting the same page, allowing cache poisoning of request-specific preview output. When running Ghost's frontend and admin panel on the same domain this could be used to take over staff user accounts. When running these on different domains staff accounts have no exposure. Vulnerable versions This vulnerability is present in Ghost from v4.0 up to v6.36.0. Patches v6.37.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-62q6-4hv4-vjrw
- Revision 2 · amended ·
Amended from osv record GHSA-62q6-4hv4-vjrw
- Revision 1 · created ·
Published from ghsa record GHSA-62q6-4hv4-vjrw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53943 Advisory: Ghost: Cache-poisoning XSS in Ghost frontend via x-ghost-preview header IDs: CVE-2026-53943, GHSA-62q6-4hv4-vjrw Record: https://patchnext.com/advisories/cve-2026-53943 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 6.37.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected >= 4.0.0, <= 6.36.0; fixed in 6.37.0 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-62q6-4hv4-vjrw (GitHub-reviewed advisory GHSA-62q6-4hv4-vjrw lists affected ranges: npm ghost >=4.0.0 <=6.36.0) - Verified: https://osv.dev/vulnerability/GHSA-62q6-4hv4-vjrw (OSV record GHSA-62q6-4hv4-vjrw lists affected ranges: npm ghost >=4.0.0 <6.37.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…