Skip to content

← Actionable
Medium, CVSS 6.9amended

Uprobe gadgets: unprivileged container's ld.so.cache causes high CPU utilization and container startup DoS

CVE-2026-53941GHSA-vjhx-2cqw-3q6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/inspektor-gadget/inspektor-gadget 0.53.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-53941: 0.52% estimated exploitation activity in the next 30 days; percentile 44.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unprivileged container can block all other containers from starting on the same host by placing a crafted /etc/ld.so.cache file in its filesystem. When Inspektor Gadget attaches any uprobe-based gadget, it parses this file in the container startup path. A malicious cache causes ~53 seconds of CPU burn, during which Docker cannot start any other container. No special capabilities are required. Severity To be assessed — Availability impact, no confidentiality or integrity impact. Affected Versions All versions of Inspektor Gadget that support uprobe-based gadgets (tracemalloc, traceopen, tracessl, tracegrpc, etc.). Description When Inspektor Gadget attaches uprobe-based gadgets to containers, it resolves library paths by parsing the container's /etc/ld.so.cache file (pkg/uprobetracer/ldcacheparser.go). This file is fully controlled by the container. The parser has three vulnerabilities: 1. Quadratic string building (pkg/uprobetracer/bytes.go:36-44): The readStringFromBytes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-vjhx-2cqw-3q6q

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6254

  4. Revision 1 · created ·

    Published from osv record GHSA-vjhx-2cqw-3q6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53941

Advisory: Uprobe gadgets: unprivileged container's ld.so.cache causes high CPU utilization and container startup DoS
IDs: CVE-2026-53941, GHSA-vjhx-2cqw-3q6q
Record: https://patchnext.com/advisories/cve-2026-53941 (revision 4, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/inspektor-gadget/inspektor-gadget 0.53.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/inspektor-gadget/inspektor-gadget: affected >= 0.27.0, < 0.53.1; fixed in 0.53.1

## Suggested inspection (read-only)
- Go github.com/inspektor-gadget/inspektor-gadget: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/inspektor-gadget/inspektor-gadget.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vjhx-2cqw-3q6q (OSV record GHSA-vjhx-2cqw-3q6q lists affected ranges: Go github.com/inspektor-gadget/inspektor-gadget >=0.27.0 <0.53.1 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6254 (OSV record GO-2026-6254 lists affected ranges: Go github.com/inspektor-gadget/inspektor-gadget >=0.27.0 <0.53.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vjhx-2cqw-3q6q (GitHub-reviewed advisory GHSA-vjhx-2cqw-3q6q lists affected ranges: Go github.com/inspektor-gadget/inspektor-gadget >=0.27.0 <0.53.1)

Commands are suggestions: review each one before running it.

Loading voting…