vLLM: GGUF dequantize kernel int truncation exposes uninitialized GPU memory in multi-tenant serving
CVE-2026-53923GHSA-5jv2-g5wq-cmr4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.5.5, < 0.24.0
- Fixed in
- 0.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5jv2-g5wq-cmr4 lists affected ranges: PyPI vllm >=0.5.5 <0.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jv2-g5wq-cmr4 lists affected ranges: PyPI vllm >=0.5.5 <0.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-53923: 0.48% estimated exploitation activity in the next 30 days; percentile 41.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Integer truncation of tensor dimensions in vLLM's GGUF dequantize kernels (csrc/quantization/gguf/ggufkernel.cu) causes partial tensor processing. The output tensor is allocated at full size via torch::empty (uninitialized memory), but the dequantize CUDA kernel processes only a truncated number of elements. The unfilled portion of the output tensor retains whatever was previously in GPU memory. In multi-tenant inference deployments, this residual GPU memory may contain tensor data from other users' inference requests, constituting information disclosure. Root Cause The tocudaggmlt function pointer type at ggml-common.h:1067 declares its element count parameter as int (32-bit): All dequantize kernel functions (dequantizeblockcuda, dequantizerowq2Kcuda, etc. in dequantize.cuh) inherit this int k parameter and use it as the kernel launch grid size: In ggmldequantize() at ggufkernel.cu:85, the caller passes m n (an int64t product) to this int k parameter: When m n INTMAX, the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5jv2-g5wq-cmr4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5jv2-g5wq-cmr4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53923 Advisory: vLLM: GGUF dequantize kernel int truncation exposes uninitialized GPU memory in multi-tenant serving IDs: CVE-2026-53923, GHSA-5jv2-g5wq-cmr4 Record: https://patchnext.com/advisories/cve-2026-53923 (revision 3, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.5.5, < 0.24.0; fixed in 0.24.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5jv2-g5wq-cmr4 (OSV record GHSA-5jv2-g5wq-cmr4 lists affected ranges: PyPI vllm >=0.5.5 <0.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5jv2-g5wq-cmr4 (GitHub-reviewed advisory GHSA-5jv2-g5wq-cmr4 lists affected ranges: PyPI vllm >=0.5.5 <0.24.0) Commands are suggestions: review each one before running it.
Loading voting…