Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker have Memory Allocation with Excessive Size Value vulnerability
CVE-2026-53917GHSA-f77w-px59-cqf5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-broker 6.2.7, 5.19.8; org.apache.activemq:apache-activemq 6.2.7, 5.19.8; org.apache.activemq:activemq-client 6.2.7, 5.19.8; org.apache.activemq:activemq-all 6.2.7, 5.19.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-broker
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Maven org.apache.activemq:apache-activemq
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Maven org.apache.activemq:activemq-client
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Maven org.apache.activemq:activemq-all
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f77w-px59-cqf5 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker. An authenticated user can cause a broker DoS by sending a crafted OpenWire Message with a large encoded size value for the map. OpenWire message property maps are unmarshaled without size validation which can trigger OOM and crash the broker. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Client: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f77w-px59-cqf5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53917 Advisory: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker have Memory Allocation with Excessive Size Value vulnerability IDs: CVE-2026-53917, GHSA-f77w-px59-cqf5 Record: https://patchnext.com/advisories/cve-2026-53917 (revision 1, source checked 4 Nov 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-broker 6.2.7, 5.19.8; org.apache.activemq:apache-activemq 6.2.7, 5.19.8; org.apache.activemq:activemq-client 6.2.7, 5.19.8; org.apache.activemq:activemq-all 6.2.7, 5.19.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-broker: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 - Maven org.apache.activemq:apache-activemq: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 - Maven org.apache.activemq:activemq-client: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 - Maven org.apache.activemq:activemq-all: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-broker: check the installed version with your package manager. - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. - Maven org.apache.activemq:activemq-client: check the installed version with your package manager. - Maven org.apache.activemq:activemq-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-broker, org.apache.activemq:apache-activemq, org.apache.activemq:activemq-client, org.apache.activemq:activemq-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f77w-px59-cqf5 (GitHub-reviewed advisory GHSA-f77w-px59-cqf5 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.7) Commands are suggestions: review each one before running it.
Loading voting…