JetBrains Kotlin: Unsafe Deserialization in Kotlin Build Cache Enables Code Execution
CVE-2026-53914GHSA-r937-wjx7-w2jp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jetbrains.kotlin:kotlin-gradle-plugin 2.4.20-Beta1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jetbrains.kotlin:kotlin-gradle-plugin
- Affected
- < 2.4.20-Beta1
- Fixed in
- 2.4.20-Beta1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r937-wjx7-w2jp lists affected ranges: Maven org.jetbrains.kotlin:kotlin-gradle-plugin >=0 <2.4.20-Beta1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2026-53914: 0.33% estimated exploitation activity in the next 30 days; percentile 26.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In JetBrains Kotlin before 2.4.20 code execution was possible via unsafe deserialization in the build cache metadata
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r937-wjx7-w2jp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53914 Advisory: JetBrains Kotlin: Unsafe Deserialization in Kotlin Build Cache Enables Code Execution IDs: CVE-2026-53914, GHSA-r937-wjx7-w2jp Record: https://patchnext.com/advisories/cve-2026-53914 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jetbrains.kotlin:kotlin-gradle-plugin 2.4.20-Beta1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jetbrains.kotlin:kotlin-gradle-plugin: affected < 2.4.20-Beta1; fixed in 2.4.20-Beta1 ## Suggested inspection (read-only) - Maven org.jetbrains.kotlin:kotlin-gradle-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jetbrains.kotlin:kotlin-gradle-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r937-wjx7-w2jp (GitHub-reviewed advisory GHSA-r937-wjx7-w2jp lists affected ranges: Maven org.jetbrains.kotlin:kotlin-gradle-plugin >=0 <2.4.20-Beta1) Commands are suggestions: review each one before running it.
Loading voting…