Skip to content

← Actionable
High, CVSS 7.1amended

JustHTML is vulnerable to XSS via code fence breakout in content

CVE-2026-5389GHSA-5vp3-3cg6-2rq3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (justhtml 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI justhtml

    Affected
    <= 1.12.0
    Fixed in
    1.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-5389: 0.23% estimated exploitation activity in the next 30 days; percentile 13.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary tomarkdown() is vulnerable when serializing attacker-controlled <pre content. The <pre handler emits a fixed three-backtick fenced code block, but writes decoded text content into that fence without choosing a delimiter longer than any backtick run inside the content. An attacker can place backticks and HTML-like text inside a sanitized <pre element so that the generated Markdown closes the fence early and leaves raw HTML outside the code block. When that Markdown is rendered by a CommonMark/GFM-style renderer that allows raw HTML, the HTML executes. This is a bypass of the v1.12.0 Markdown hardening. That fix escaped HTML-significant characters for regular text nodes, but <pre uses a separate serialization path and does not apply the same protection. Details The vulnerable <pre Markdown path: - extracts decoded text from the <pre subtree - opens a fenced block with a fixed delimiter of - writes the decoded text directly into the output - closes with another fixed Because the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5vp3-3cg6-2rq3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5vp3-3cg6-2rq3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-5389

Advisory: JustHTML is vulnerable to XSS via code fence breakout in content
IDs: CVE-2026-5389, GHSA-5vp3-3cg6-2rq3
Record: https://patchnext.com/advisories/cve-2026-5389 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: justhtml 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI justhtml: affected <= 1.12.0; fixed in 1.13.0

## Suggested inspection (read-only)
- `python -m pip show justhtml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on justhtml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5vp3-3cg6-2rq3 (OSV record GHSA-5vp3-3cg6-2rq3 lists affected ranges: PyPI justhtml >=0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5vp3-3cg6-2rq3 (GitHub-reviewed advisory GHSA-5vp3-3cg6-2rq3 lists affected ranges: PyPI justhtml >=0 <=1.12.0)

Commands are suggestions: review each one before running it.

Loading voting…